activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suchitha Koneru (sukoneru)" <sukon...@cisco.com>
Subject subscriber issues.
Date Mon, 16 Jun 2008 19:59:44 GMT
Hello All , 
                We use the active mq broker for exchanging the messages
between two JVM's.  One JVM is a tomcat server and the other other is
stand alone java process. The active MQ broker is started by one of the
threads in the stand  alone have process.
We use durable subscribers and non persistent delivery of messages. 
 
 There is one durable subscriber and topic publisher per JVM. After
running for 2-3 days the subscriber in the Tomcat server stops receiving
messages , Iam not sure if the subscriber died or if it is blocked , or
if the TCP socket got closed.  I do not see any exceptions in the logs.
 
Any insights into debugging this issue  ? Is there a way I can look at
all the threads and ports being used by active MQ ?  Can I print the
ports at which the subscriber and publisher are running in the logs. 
 
 
The broker url is  as follows 
failover/:tcp/://ipAddress/:portNumber
The maxInactivity duration is set as -1 
 
Version of Tomcat : 5.5.9
Active Mq Version : 4.1.1
Java 1.6
 
The durable subscriber in Tomcat  server is configured as per the
example
http://activemq.apache.org/setting-up-activemq-with-tomcat-559.html.
 
thank you,
suchitha.
 
 
 
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message