activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dejan Bosanac" <de...@nighttale.net>
Subject Re: Producer Stops Sending messages
Date Wed, 18 Jun 2008 10:05:22 GMT
Hi Mike,

do you use pooled connection factory?

Take a look at
http://activemq.apache.org/spring-support.html#SpringSupport-WorkingwithSpring%27sJmsTemplate
http://activemq.apache.org/jmstemplate-gotchas.html

for more info about producing messages with JmsTemplate

Cheers
-- 
Dejan Bosanac
www.scriptinginjava.net

On Wed, Jun 18, 2008 at 11:38 AM, michaellear <mikelear@condotta.co.uk>
wrote:

>
> Hi
>
>   I wonder if some maybe able to help in some problems we are having when
> sending messages to our Broker. I'm new to activemq and as a company we are
> looking at introducing it. We are using
>
> unbuntu version 2.6.24
> ActiveMQ 5.1
> Java 1.6
> spring 2.5
>
> I have a spring application that connects to a database and reads 60,000
> rows as each row is processed I create a message using springs
> jmsTemplate.send with  a MessageCreator creating a MapMessage. This all
> works fine for about 5000 messages and then the producer just stops. I've
> got DEBUg on and it just stops after ActiveMQSession.send. I changed the
> connection string to include wireFormat.maxInactivityDuration=0 but this
> doesn't make any difference except that when this isn't set the DEBUG
> InactivityMonitor outputs messages. Any help would be greatly appreciated.
>
>
> Thanks
>
> Mike
> --
> View this message in context:
> http://www.nabble.com/Producer-Stops-Sending-messages-tp17979168p17979168.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message