activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From qrtt1 <chingyichan...@gmail.com>
Subject Cannot run maven perftest
Date Mon, 23 Jun 2008 09:33:56 GMT

Cannot run maven perftest

Hello,

I check out the ActiveMQ source code, 
and use maven compile the activemq-console and activemq-tooling.
Compiling is success, but I cannot run it to do performance test.

The error messages are ...

C:\APP\activemq\activemq-tooling>mvn -e activemq-perf:broker
-Durl=broker:tcp://localhost:61616
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] Reactor build order:
[INFO]   ActiveMQ Tooling
[INFO]   ActiveMQ :: Memory Usage Test Plugin
[INFO]   ActiveMQ :: Performance Test Plugin
[INFO]   ActiveMQ :: StartUp Plugin
[INFO] Searching repository for plugin with prefix: 'activemq-perf'.
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] The plugin 'org.apache.maven.plugins:maven-activemq-perf-plugin' does
not exist or no valid version could be found
[INFO]
------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: The plugin
'org.apache.maven.plugins:maven-activemq-perf-plugin' does not exist or no
valid version could be found
        at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1303)
        at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.getMojoDescriptor(DefaultLifecycleExecutor.java:1542)
        at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.segmentTaskListByAggregationNeeds(DefaultLifecycleExecutor.java:405)
        at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:137)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:287)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at
org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
        at
org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)

        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
Caused by: org.apache.maven.plugin.version.PluginVersionNotFoundException:
The plugin 'org.apache.maven.plugins:maven-activemq-perf-plugin' does not
exist or no valid version could be found
        at
org.apache.maven.plugin.version.DefaultPluginVersionManager.resolvePluginVersion(DefaultPluginVersionManager.java:229)
        at
org.apache.maven.plugin.version.DefaultPluginVersionManager.resolvePluginVersion(DefaultPluginVersionManager.java:91)
        at
org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:171)
        at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1274)
        ... 14 more
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 1 second
[INFO] Finished at: Mon Jun 23 17:18:41 CST 2008
[INFO] Final Memory: 6M/11M
[INFO]
------------------------------------------------------------------------


However, I go to the .m2 directory and find the ActiveMQ plugins installed
directory
C:\Documents and
Settings\Administrator\.m2\repository\org\apache\activemq\tooling

the maven-metadata-local.xml is there and it looks good

=============================  maven-metadata-local.xml ==
<?xml version="1.0" encoding="UTF-8"?><metadata>
  <plugins>
    <plugin>
      <name>ActiveMQ :: Memory Usage Test Plugin</name>
      <prefix>activemq-memtest</prefix>
      <artifactId>maven-activemq-memtest-plugin</artifactId>
    </plugin>
    <plugin>
      <name>ActiveMQ :: Performance Test Plugin</name>
      <prefix>activemq-perf</prefix>
      <artifactId>maven-activemq-perf-plugin</artifactId>
    </plugin>
    <plugin>
      <name>ActiveMQ :: StartUp Plugin</name>
      <prefix>activemq</prefix>
      <artifactId>maven-activemq-plugin</artifactId>
    </plugin>
  </plugins>
</metadata>
=============================  maven-metadata-local.xml ==

I have no idea to do something make it runnable. 
Anyone can help me?

p.s. maven is version 2.0.9
jdk is version 1.6.0_06
os is xp
activemq is r670451
-- 
View this message in context: http://www.nabble.com/Cannot-run-maven-perftest-tp18065669p18065669.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message