activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eeiddne <donal.du...@ericsson.com>
Subject ActiveMQ on Solaris 10 under SMF control will not online
Date Tue, 17 Jun 2008 11:03:36 GMT

Hi,

We have just installed ActiveMQ on Solaris 10 and have created a manifest
file in order to place the ActiveMQ process under SMF control.

Problem is the SMF service manages to start the process, but it will not
online. If a timeout is inserted for the start command, it times out as if
the process has not started properly.

I notice when I start ActiveMQ from the prompt, it does not return to the
shell unless the "&" is added after the command. Could this be confusing SMF
into thinking the service has not started properly?

See xml manifest below...

/D

<?xml version="1.0"?>
<!DOCTYPE service_bundle SYSTEM
"/usr/share/lib/xml/dtd/service_bundle.dtd.1">

<service_bundle type='manifest' name='ERICactmq:activemq'>

<service
        name='ericsson/eric_3pp/activemq'
        type='service'
        version='1'>

                <create_default_instance enabled='true' />

        <single_instance/>

        <dependency
                name='activemq-multi-user-server-milestone'
                grouping='require_all'
                restart_on='none'
                type='service'>
                <service_fmri value='svc:/milestone/multi-user-server' />
        </dependency>

        <exec_method
                type='method'
                name='start'
                exec='/opt/activemq/bin/activemq'
                timeout_seconds='60' >
        </exec_method>

        <exec_method
        type='method'
        name='stop'
        exec=':kill'
        timeout_seconds='60' >
        </exec_method>

        <stability value='Unstable' />

        <template>
                <common_name>
                        <loctext xml:lang='C'> ossrc install
                        </loctext>
                </common_name>
        </template>
</service>

</service_bundle>

-- 
View this message in context: http://www.nabble.com/ActiveMQ-on-Solaris-10-under-SMF-control-will-not-online-tp17882825p17882825.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message