activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GeorgeM <george_mard...@yahoo.com>
Subject 'org.apache.activemq.ra.ActiveMQResourceAdapter' should implement java.io.Serializable but does not
Date Thu, 12 Jun 2008 10:00:10 GMT

Hi everybody,

I deployed activemq RAR 5.1.0 (bundled in an EAR application) as an embedded
broker on weblogic 9.2. It works as expected, but I get the following
warning at the broker startup:

<Jun 10, 2008 12:07:56 PM EEST> <Notice> <Security> <BEA-090082> <Security
initializing using security realm myrealm.>
<Jun 10, 2008 12:07:59 PM EEST> <Notice> <WebLogicServer> <BEA-000365>
<Server state changed to STANDBY>
<Jun 10, 2008 12:07:59 PM EEST> <Notice> <WebLogicServer> <BEA-000365>
<Server state changed to STARTING>
<Jun 10, 2008 12:08:03 PM EEST> <Warning> <Connector> <BEA-190155>
<Compliance checking/validation of the resource adapter
C:\bea\user_projects\domains\base_domain92\servers\AdminServer\tmp\_WL_user\_appsdir_antragsnummern-application_ear\cb0xh4\activemq-rar-5.1.0.rar
resulted in the following warnings:
The ra.xml <resourceadapter-class> class
'org.apache.activemq.ra.ActiveMQResourceAdapter' should implement
java.io.Serializable but does not.>
....

I noticed that ActiveMQResourceAdapter class used to implement Serializable
in 4.1.2 release, but it doesn't implement it anymore in 5.1.0 release.

I tried to find an answer on the forum, but I didn't find one. So is there
an explanation for this change? How to avoid this warning in the weblogic
log file?

Thanks and Best regards,
George.
-- 
View this message in context: http://www.nabble.com/%27org.apache.activemq.ra.ActiveMQResourceAdapter%27-should-implement-java.io.Serializable-but-does-not-tp17796470p17796470.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message