activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From balderman <balder...@gmail.com>
Subject Problem using http transportConnector
Date Tue, 03 Jun 2008 07:40:00 GMT

I am using http tansport in order to cross firewall.
I have message broker configured to support http.

activemq.xml snippet:
~~~~~~~~~~~~~~~~~~~~
	...
	<transportConnectors>
            <transportConnector name="openwire" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/>
            <transportConnector name="ssl" uri="ssl://localhost:61617"/>
            <transportConnector name="stomp" uri="stomp://localhost:61613"/>
            <transportConnector name="xmpp" uri="xmpp://localhost:61222"/>
            <transportConnector name="http"
uri="http://172.16.233.50:61618"/>
        </transportConnectors>
	...
and have 2 java programs: "Sender" and "Receiver". I am using Spring JMS
template and Spring MDP.
The "Sender" send messages without a problem (I can browse thw queue with
the admin console).
But the "Receiver" is not getting the message. When I change the "Receiver"
configuration from http to tcp the "Receiver" gets the messages.

Sender configuration:
~~~~~~~~~~~~~~~~~~~~~
...
  <bean id="myJmsTemplate" class="org.springframework.jms.core.JmsTemplate">
    <property name="connectionFactory">
      <ref bean="jmsFactory"/>
    </property>
  </bean>

  <bean id="jmsFactory"
class="org.apache.activemq.pool.PooledConnectionFactory"
destroy-method="stop">
    <property name="connectionFactory">
      <bean class="org.apache.activemq.ActiveMQConnectionFactory">
        <property name="brokerURL">
          <value>http://172.16.233.50:61618</value>
        </property>
      </bean>
    </property>
  </bean>
  
  
  <bean id="destination" class="org.apache.activemq.command.ActiveMQQueue">
    <constructor-arg value="MyQ"/>
  </bean

Receiver configuration:
~~~~~~~~~~~~~~~~~~~~~~~
...
	<!-- this is the Message Driven POJO (MDP) -->
	<bean id="messageListener"
		class="com.bmc.disco.jms.poc.MessgeDrivenPojo" />

	<bean id="connectionFactory"
class="org.apache.activemq.ActiveMQConnectionFactory">
		<property name="brokerURL">
		        <value>http://172.16.233.50:61618</value>
		</property>
	</bean>

	<!-- and this is the message listener container -->
	<bean id="jmsContainer"
		class="org.springframework.jms.listener.DefaultMessageListenerContainer">
		<property name="connectionFactory" ref="connectionFactory" />
		<property name="destination" ref="destination" />
		<property name="messageListener" ref="messageListener" />
	</bean>

	  <bean id="destination" class="org.apache.activemq.command.ActiveMQQueue">
	    <constructor-arg value="MyQ"/>
	  </bean
...


The classpath of "Sender" and  "Receiver": 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
activeio-core-3.1.0-tests.jar
activeio-core-3.1.0.jar
activemq-core-5.1.0.jar
activemq-jmdns_1.0-5.1.0.jar
activemq-optional-5.1.0.jar
activemq-rar-5.1.0.rar
activemq-xmpp-5.1.0.jar
commons-beanutils-1.6.1.jar
commons-collections-3.1.jar
commons-dbcp-1.2.jar
commons-httpclient-2.0.1.jar
commons-logging-1.1.jar
commons-pool-1.4.jar
derby-10.1.3.1.jar
geronimo-j2ee-connector_1.5_spec-2.0.0.jar
geronimo-j2ee-management_1.0_spec-1.0.jar
geronimo-jta_1.0.1B_spec-1.0.1.jar
jms.jar
log4j-1.2.14.jar
spring-2.5.jar
spring-beans-2.5.1.jar
spring-context-2.5.1.jar
spring-core-2.5.1.jar
spring-jms-2.5.1.jar
spring-tx-2.5.1.jar
xbean-spring-3.3.jar
xmlpull-1.1.3.4d_b4_min.jar
xstream-1.2.jar


Thanks

Avishay
-- 
View this message in context: http://www.nabble.com/Problem-using-http-transportConnector-tp17617888s2354p17617888.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message