activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: ActiveMQ-CPP Version 2.2 RC1
Date Fri, 06 Jun 2008 11:23:14 GMT
Can you capture your thoughts in a JIRA issue, I will be away for a
couple days and need the reminder when I get back.

Some Comments in-line:

On Thu, 2008-06-05 at 21:09 -0700, Nathan Mittler wrote:
> Awesome job getting this out, Tim!
> 
> I checked out the tag on OS X and built and ran the unit tests.   
> Everything builds cleanly, but I did notice a couple of failed unit  
> tests (both in MathTest):
> 
> 1) test: decaf::lang::MathTest::test_hypot_DD (F) line: 262 decaf/lang/ 
> MathTest.cpp
> equality assertion failed
> - Expected: 1.79769313486232e+308
> - Actual  : inf
> - Should return 1.7976931348623157E308
> 

Not sure on this one, lets just comment it out since we aren't using it
anywhere yet.

> 
> 2) test: decaf::lang::MathTest::test_tanD (F) line: 567 decaf/lang/ 
> MathTest.cpp
> equality assertion failed
> - Expected: 1.5574077246549
> - Actual  : 1.5574077246549
> - Incorrect answer
> 

Should be easy to fix.

> Generally, these are just bothersome errors that probably don't need a  
> lot of attention.  The second one seems to just be an error in some  
> far off decimal place.  We can take care of that by just multiplying  
> the values and casting to long before comparing.  The first is a  
> little trickier - I'm not sure what the fix is.  Perhaps an temporary  
> solution is to just #ifdef it out for OS X?
> 
> Integration tests still fail in the openwire durable test.  I didn't  
> check to see if this issue was resolved or not for the release, but  
> perhaps it was pushed out.

This was fixed, at least it now works on all the platforms that I can
test on.  The issue being that the RemoveSubscriptionInfo message that
was generated did not have a command ID properly set by the openwire
generator tool.  I fixed it by hand since I can't get the generator to
work anymore, so it should work for you.  If you are sure you ran the
right executable then you may have to debug a bit to see what is
breaking on OS/X since I don't ever see a failure on that test anymore.
What version of the broker are you running?

> 
> Also the release will need a RELEASE_NOTES.txt file in the top-level  
> directory.

As far as I can tell there is a RELEASE_NOTES.txt in there, what am I
missing?

> 
> Overall, looks good ... great job getting the RC out there - there's a  
> lot of good stuff here!!
> 
> Regards,
> Nate
> 
> On Jun 4, 2008, at 4:32 PM, Timothy Bish wrote:
> 
> > Hey everyone,
> > It's official ... ActiveMQ-CPP v2.2 now has a release candidate, RC1.
> > We've also found and fixed numerous bugs along the way.  I've  
> > created a
> > download page here:
> > http://activemq.apache.org/cms/activemq-cpp-22-release.html
> > ... Feel free to give it a test drive!  The more eyes we have on this
> > now the less chance there are that small issues will slip through into
> > the final release.
> >
> > The links on this page won't work until the release is official.  For
> > now, follow the instructions at the top to download the release
> > candidate:
> > http://people.apache.org/~tabish/activemq-cpp-2.2-RC1-src.tar.gz
> >
> > Of note is that this upcoming release will now require that you have  
> > the
> > APR and APR-util libraries installed.  See the README for more info.
> >
> > Thanks to everyone that helped get this out the door!
> >
> > Regards,
> > Tim
> >
> 


Mime
View raw message