activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: ActiveMQ 5.x hangs. How to debug?
Date Wed, 21 May 2008 10:48:55 GMT

On 21 May 2008, at 10:35, Artur Siekielski wrote:

>
> Hi.
> We use ActiveMQ 5.1.0 in the following way: we have four queues,  
> each queue
> has about 5-12 consumers and producers, some of them are running on
> different machines. Used transport is 'tcp'. Producers use non- 
> persistent
> delivery mode, acknowledge mode is "auto". We do not create threads.
> Messages are consumed synchronously using 'consumer.receive()'.  
> Exact number
> of messages which have to be consumed/produced is known in advance.
>
> Everything works ok for some time (like 0,5h), but after processing  
> eg. 500
> 000 messages all consumers of a specific queue hang. In admin  
> console there
> are a few pending messages in that queue. How can we debug such  
> situation?
> Turning DEBUG logging in broker didn't give us any useful information.
>
> We have switched to latest ActiveMQ from 4.x branch and didn't  
> experience
> hang situation yet (but more tests are needed).
>
> Any help would be appreciated,
> Artur
> -- 
> View this message in context: http://www.nabble.com/ActiveMQ-5.x-hangs.-How-to-debug--tp17359508s2354p17359508.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Stack trace - and preferably a single  junit test case - attached to a  
jira would help identify the problem quicker


cheers,

Rob

http://open.iona.com/products/enterprise-activemq
http://rajdavies.blogspot.com/





Mime
View raw message