activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Franz <MFr...@FFTW.COM>
Subject Re: ActiveMQ and XMPP not functioning
Date Thu, 29 May 2008 15:08:39 GMT

I am having a similar problem using ActiveMQ 5.1.0.  The spark client
connects, but fails to launch the conference.  The Spark logs have a NPE in
the UI thread.  Since Spark 2.5.8 was released in April 2006 I am assuming
that it has worked as stated in the example.

Are there any other Jabber clients that are know to work with xmpp to talk
to ActiveMQ?

Michael

suedonne123 wrote:
> 
> I have installed and tested ActiveMQ 4.2.2 under JBoss 5.0.0 and Java6.
> I am able to send/receive messages so I know the activemq installation is
> correct.
> 
> I am trying to enable XMPP and use a Spark client to join conference
> (subscribe to topic).
> Following the directions in  http://activemq.apache.org/xmpp.html
> I am able to login and I can see in the Jboss/activemq logs the following
> message:
> 
> 13:01:40,266 WARN  [ProtocolConverter] Iq Unknown  to: null type: get
> from: null id: 1zOtP-4 element namespace:
> http://www.jivesoftware.org/protocol/sharedgroup localName: sharedgroup
> 13:01:40,282 WARN  [ProtocolConverter] Iq Unknown  to: null type: get
> from: sad@com.fortna.sueBroker/spark id: 1zOtP-5 element namespace:
> vcard-temp localName: vCard
> 
> (which I understand to be normal)...
> 
> MY PROBLEM IS THIS, 
> when I click on the Join Conference button...OR the start conference menu
> item...
> nothing happens.
> 
> It appears that this functionality is disabled in Spark client...
> Is this due to some configuration that happens on initial authentication
> with Jabber server (activeMQ
> in this case???) 
> 
> Here is more information on what I have tried:
> At first, I had been running against Java 1.6 and when Join Conference
> button was pressed, I would
> get an error in the activemq logs regarding Linkage error that
> jaxb-api.jar was 2.0 and 2.1 was expected and I should use the endorsed
> libs stuff to put the 2.1 version out there...
> 
> I changed my Jboss installation to run against 1.5 and now I get no error
> messages and I get
> no messages at all in the activemq/jboss logs that give me any indication
> that the Spark client
> did anything (I am guessing that it should have sent a message to the
> Jabber server)...
> 
> I have found 1 or 2 postings which list some missing jars that this stuff
> depends on...
> Such as stax, etc...
> 
> Can someone give me the exact list of jars and jar versions that are
> required to run xmpp transport????
> 
> And What should the jars and jar versions be under Java 5 versus Java 6???
> 
> 
> Thank you.
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ-and-XMPP-not-functioning-tp16147069s2354p17536302.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message