activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benoitx <beno...@yahoo.com>
Subject 5.1.0 Network Brokers: changes since 4.1.1?
Date Tue, 13 May 2008 11:41:59 GMT

Hi All,

We’re using ActiveMQ with Mule 1.4.4-SNAPSHOT.

I've just upgraded from ActiveMQ 4.1.1 to 5.1.0 and suddenly all my network
of brokers keep the messages in the local queues!  I think it is an issue
related to the first broker not forwarding messages to the second broker as
we have an old 4.1.1 broker part of the network and it is the only one that
is able to forward to BrokerB... 

I have checked the documentation
http://activemq.apache.org/networks-of-brokers.html and the configuration
does not seem to have changed between 4.1.1 and 5.1.0 (at least for the
network of brokers?)

BrokerA: 
<networkConnectors> 
    <networkConnector name="brokerA" uri="static://(tcp://localhost:27000)"
dynamicOnly="true">        <excludedDestinations> 
            <queue physicalName="*" /> 
            <queue physicalName=">" /> 
            <topic physicalName="*" /> 
            <topic physicalName=">" /> 
        </excludedDestinations> 
        <dynamicallyIncludedDestinations> 
            <queue physicalName="queue.client1.from" /> 
        </dynamicallyIncludedDestinations> 
    </networkConnector> 
</networkConnectors> 

and BrokerB (where the consumers are) 
<transportConnectors> 
        <transportConnector uri="tcp://localhost:27000" /> 
</transportConnectors> 

The messages stay in the queue "queue.client1.from" in BrokerA as confirmed
by the JConsole (JMX interface).

However, if I do NOT use
excludedDestinations/dynamicallyIncludedDestinations, it works but for all
queues (not suitable for us)
<networkConnectors> 
    <networkConnector name="brokerA" uri="static://(tcp://localhost:27000)"
/>           
</networkConnectors> 

And now… if I use only the dynamicallyIncludedDestinations, it also works…
<networkConnector name="objectlab-esb-client-to-esb-server-client1"
uri="static:(tcp://localhost:27000)" dynamicOnly="true">
  <excludedDestinations>
  </excludedDestinations>
  <dynamicallyIncludedDestinations>
    <queue physicalName="queue.client1.from" />
  </dynamicallyIncludedDestinations>
</networkConnector>

Basically as soon as something is put in excludedDestinations nothing is
sent to the forward queue, even if it is only <topic physicalName="*" /> or
<topic physicalName=">" /> which should only stop topics right? Why is it
the case? Is it expected behaviour?

If BrokerA, with the initial configuration, runs activeMQ 4.1.1 it all works
ok...  so it is a change in xml interpretation between 4.1.1…

Is that correct or am I wrong?

Could the documentation on
http://activemq.apache.org/networks-of-brokers.html be more explicit?

Thanks a lot 
Benoit 
http://www.Appendium.com

-- 
View this message in context: http://www.nabble.com/5.1.0-Network-Brokers%3A-changes-since-4.1.1--tp17206477s2354p17206477.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message