activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: ActiveMQ-5.1.0-RC3 - Messages going missing
Date Tue, 22 Apr 2008 05:12:02 GMT
Are you using networks as well ?

On 22 Apr 2008, at 04:01, alanmc wrote:

>
> We're seeing the same behavior with 5.1.0.  We're basically running  
> the
> default broker configuration, with advisory support turned off.  We  
> were
> using 5.0.0, but saw memory leakage and wanted to try out 5.1.0 and  
> after
> switching over with the exact same configuration we started seeing
> intermittent message dropping, probably about 1 in 3 messages going  
> missing.
> The broker shows all messages as enqueued and dequeued.
>
> We're using ActiveMQ as middleware between a website and back-end  
> services.
> We run python clients and model Request-Reply by creating a temp  
> queue and
> sending the request with the reply-to attribute populated.  Works  
> great on
> 5.0.0 (except for troubling memory usage), but switch to 5.1.0 and 1  
> in 3
> messages just disappear.
>
>
> Dhruba Bandopadhyay-2 wrote:
>>
>> Further to this I'd like to add that the broker shows that all 20000
>> messages have been enqueued and dequeued.  So the broker queue has no
>> messages remaining on it.
>>
>> On Thu, Apr 17, 2008 at 2:24 PM, Dhruba Bandopadhyay <bdhruba@gmail.com 
>> >
>> wrote:
>>> Hi,
>>>
>>> Using spring 2.5.3 mdps, tomcat 6.0.16 and activemq 5.1.0-rc3 with 1
>>> producer, 3 brokers and 1 consumer running 5 threads with almost
>>> default broker configuration.
>>
>>> Is this correct behaviour given my setup?  What are the usual causes
>>> of messages going missing?  I don't see any exceptions or failures
>>> anywhere.  The consumer stats show that the consumer has only
>>> processed roughly 19000 messages so it is definitely not the case  
>>> that
>>> it is has processed them but failed to do so correctly.
>>>
>>> Any help, advice or link to appropriate documentation would be much
>>> appreciated as for me this is a serious problem.
>>>
>>> Many thanks.
>>>
>>
>>
>
> -- 
> View this message in context: http://www.nabble.com/ActiveMQ-5.1.0-RC3---Messages-going-missing-tp16746451s2354p16820504.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


Mime
View raw message