activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DA <dile...@pramati.com>
Subject sending message from an external client
Date Tue, 29 Apr 2008 09:26:04 GMT

Hi all,
My application runs on jboss and i configured activewq for
messsaging.everything is working fine messaging r flowing fine.Now i want to
send message to this queue from an external client a main program.
i created the initialcontext with the properties from jboss

java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory
java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces

now when i did a lookup for connectionfatory it is returning me null. On
debugging it i found that it actually found the connectionfactory but in
NamingManager.getObjectInstance at

factory = getObjectFactoryFromReference(ref, f);
		if (factory != null) {
		    return factory.getObjectInstance(ref, name, nameCtx,
						     environment);
		}

it is returning null. Before going there, ref is holding the
connectionfactory instance.

i observed that factory is "org.jboss.util.naming.NonSerializableFactory"

in that factory.getObjectInstance it is looking for  connectionfactoryName
in a map and simply returning null from there.

can any one tell me what is happening there and what is wrong in my code.

Thanks in advance.
  DA
-- 
View this message in context: http://www.nabble.com/sending-message-from-an-external-client-tp16956671s2354p16956671.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message