activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hatta <rmi_j...@yahoo.com>
Subject Re: Using activemq as a jabber server
Date Wed, 23 Apr 2008 08:04:35 GMT

Hi there,

May I know the reference to the wiki which James has updated. I would also
like to know how to turn off the auto discovery of the server



Abdullah Jibaly-3 wrote:
> 
> Just a note that this turned out to be the Spark client itself. James
> added a note on the wiki showing how to turn off auto discovery of
> server/port so shouldn't be an issue anymore.
> 
> On 3/9/07, James Strachan <james.strachan@gmail.com> wrote:
>> BTW do you see any DEBUG statements showing that the XMPP transport in
>> ActiveMQ is receiving messages over XMPP?
>>
>> On 3/9/07, James Strachan <james.strachan@gmail.com> wrote:
>> > Are you sure there's not a firewall or something between your Spark
>> > client and the broker?
>> >
>> > On 3/9/07, Abdullah Jibaly <amjibaly@gmail.com> wrote:
>> > > Here's the only exception I saw when I changed the log level to
>> debug:
>> > >
>> > > DEBUG ManagementContext              - Failed to create local
>> registry
>> > > java.lang.ClassNotFoundException: mx4j.tools.naming.NamingService
>> > >         at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
>> > >         at java.security.AccessController.doPrivileged(Native Method)
>> > >         at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
>> > >         at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>> > >         at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
>> > >         at
>> java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
>> > >         at java.lang.Class.forName0(Native Method)
>> > >         at java.lang.Class.forName(Class.java:169)
>> > >         at
>> org.apache.activemq.broker.jmx.ManagementContext.createConnector(ManagementContext.java:386)
>> > >         at
>> org.apache.activemq.broker.jmx.ManagementContext.findMBeanServer(ManagementContext.java:301)
>> > >         at
>> org.apache.activemq.broker.jmx.ManagementContext.getMBeanServer(ManagementContext.java:154)
>> > >         at
>> org.apache.activemq.broker.jmx.ManagementContext.start(ManagementContext.java:78)
>> > >         at
>> org.apache.activemq.broker.BrokerService.start(BrokerService.java:405)
>> > >         at
>> org.apache.activemq.xbean.XBeanBrokerService.afterPropertiesSet(XBeanBrokerService.java:47)
>> > >         at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(Abst
>> > > ractAutowireCapableBeanFactory.java:1062)
>> > >         at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(Abstrac
>> > > tAutowireCapableBeanFactory.java:1029)
>> > >         at
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAut
>> > > owireCapableBeanFactory.java:420)
>> > >         at
>> org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:
>> > > 245)
>> > >         at
>> org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingleto
>> > > nBeanRegistry.java:141)
>> > >         at
>> org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:242)
>> > >
>> > >         at
>> org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:156)
>> > >
>> > >         at
>> org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(Defau
>> > > ltListableBeanFactory.java:290)
>> > >         at
>> org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.j
>> > > ava:348)
>> > >         at
>> org.apache.xbean.spring.context.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContex
>> > > t.java:161)
>> > >         at
>> org.apache.xbean.spring.context.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContex
>> > > t.java:51)
>> > >         at
>> org.apache.activemq.xbean.XBeanBrokerFactory.createBroker(XBeanBrokerFactory.java:41)
>> > >         at
>> org.apache.activemq.broker.BrokerFactory.createBroker(BrokerFactory.java:57)
>> > >         at
>> org.apache.activemq.console.command.StartCommand.startBroker(StartCommand.java:82)
>> > >         at
>> org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:47)
>> > >         at
>> org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:50)
>> > >         at
>> org.apache.activemq.console.command.ShellCommand.runTask(ShellCommand.java:105)
>> > >         at
>> org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:50)
>> > >         at
>> org.apache.activemq.console.command.ShellCommand.main(ShellCommand.java:77)
>> > >         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
>> Method)
>> > >         at
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> > >         at
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> > >         at java.lang.reflect.Method.invoke(Method.java:597)
>> > >         at
>> org.apache.activemq.console.Main.runTaskClass(Main.java:206)
>> > >         at org.apache.activemq.console.Main.main(Main.java:95)
>> > >
>> > > On 3/9/07, James Strachan <james.strachan@gmail.com> wrote:
>> > > > I'm a bit stumped on this one. All I can think of right now is you
>> > > > enable debug logging in the log4j.properties file and see if that
>> > > > helps any
>> > > >
>> > > > On 3/9/07, Abdullah Jibaly <amjibaly@gmail.com> wrote:
>> > > > > Here is a screenshot showing the error I'm getting, as well as
my
>> activemq.xml:
>> > > > >
>> > > > > <beans>
>> > > > >         <broker xmlns="http://activemq.org/config/1.0">
>> > > > >     <transportConnectors>
>> > > > >        <transportConnector name="openwire"
>> uri="tcp://localhost:61616"
>> > > > > discoveryUri="multicast://default"/>
>> > > > >        <transportConnector name="stomp"   
>> uri="stomp://localhost:61613"/>
>> > > > >        <transportConnector name="xmpp"    
>> uri="xmpp://localhost:61222"/>
>> > > > >     </transportConnectors>
>> > > > >   </broker>
>> > > > > </beans>
>> > > > >
>> > > > >
>> > > > > On 3/9/07, Abdullah Jibaly <amjibaly@gmail.com> wrote:
>> > > > > > I forgot to mention, I also tried that
>> simpleAuthenticationPlugin
>> > > > > > sample, put it in my activemq.xml but the command agent
then
>> fails to
>> > > > > > startup. I'm running off of the svn trunk and built activemq
>> using
>> > > > > > maven.
>> > > > > >
>> > > > > > Thanks,
>> > > > > > Abdullah
>> > > > > >
>> > > > > > On 3/9/07, Abdullah Jibaly <amjibaly@gmail.com> wrote:
>> > > > > > > Hi James,
>> > > > > > >
>> > > > > > > Thanks for the response. The method you outlined is
exactly
>> what I
>> > > > > > > want to use it for. However, I think my question is
much more
>> basic:
>> > > > > > > In the xmpp page you have an example with spark, using
a
>> username and
>> > > > > > > password right? How do I configure a username and password
is
>> my
>> > > > > > > question? I tried putting in a random username and
password
>> and i get
>> > > > > > > back "invalid username/password"...
>> > > > > > >
>> > > > > > > Thanks,
>> > > > > > > Abdullah
>> > > > > > >
>> > > > > > > On 3/9/07, James Strachan <james.strachan@gmail.com>
wrote:
>> > > > > > > > On 3/8/07, Abdullah Jibaly <amjibaly@gmail.com>
wrote:
>> > > > > > > > > Hi all,
>> > > > > > > > >
>> > > > > > > > > I'm having trouble setting up ActiveMQ as
a Jabber
>> server. I tried to
>> > > > > > > > > follow the directions on the xmpp page but
there are lots
>> of holes in
>> > > > > > > > > it. For example, how do I configure the
>> username/password, where do i
>> > > > > > > > > set those up? Has anyone been able to follow
that
>> assuming no other
>> > > > > > > > > knowledge of ActiveMQ? BTW, I followed the
article on
>> Infoq regarding
>> > > > > > > > > activemessaging so I was able to get messages
getting
>> sent just fine,
>> > > > > > > > > but had no luck with xmpp. Also, I had to
build activemq
>> from source
>> > > > > > > > > using maven because the latest 4.1 binaries
do not
>> include the xmpp
>> > > > > > > > > transport.
>> > > > > > > > >
>> > > > > > > > > So in summary:
>> > > > > > > > >
>> > > > > > > > > How do i setup jabber users so they can connect?
>> > > > > > > >
>> > > > > > > > Note that the XMPP support is not really meant
as a fully
>> fledged
>> > > > > > > > Jabber server supporting all of the various Jabber
features
>> - its more
>> > > > > > > > a way to be able to use your Jabber client to
talk to
>> ActiveMQ as a
>> > > > > > > > kinda management/operational tool
>> > > > > > > >
>> > > > > > > > The out of the box default has no security enabled,
so you
>> don't need
>> > > > > > > > to worry about configuring anything if you just
want to get
>> things
>> > > > > > > > going - just enable the xmpp transport connector
in
>> activemq.xml.
>> > > > > > > >
>> > > > > > > > If you want to enable some kinda security mechanism,
see...
>> > > > > > > > http://activemq.apache.org/security.html
>> > > > > > > > --
>> > > > > > > >
>> > > > > > > > James
>> > > > > > > > -------
>> > > > > > > > http://radio.weblogs.com/0112098/
>> > > > > > > >
>> > > > > > >
>> > > > > >
>> > > > >
>> > > > >
>> > > >
>> > > >
>> > > > --
>> > > >
>> > > > James
>> > > > -------
>> > > > http://radio.weblogs.com/0112098/
>> > > >
>> > >
>> >
>> >
>> > --
>> >
>> > James
>> > -------
>> > http://radio.weblogs.com/0112098/
>> >
>>
>>
>> --
>>
>> James
>> -------
>> http://radio.weblogs.com/0112098/
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/Using-activemq-as-a-jabber-server-tp9383439s2354p16833210.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message