activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kalana <kalg...@yahoo.com>
Subject client already connected with same clientId error
Date Fri, 04 Apr 2008 17:18:04 GMT

We use fuse-message-broker-5.0.0.9, which we use to create a connection
factory. And after running the service for sometime, we can't connect to the
Activemq(new Sessions). It will give and error saying we are trying to
connect from the same clientId.
Please see the stack strace below.

javax.jms.InvalidClientIDException: Broker: localhost - Client: rClient
already connected from /192.168.0.12:49170
        at
org.apache.activemq.broker.region.RegionBroker.addConnection(RegionBroker.java:211)
        at
org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:81)
        at
org.apache.activemq.advisory.AdvisoryBroker.addConnection(AdvisoryBroker.java:73)
        at
org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:81)
        at
org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:88)
        at
org.apache.activemq.broker.TransportConnection.processAddConnection(TransportConnection.java:660)
        at
org.apache.activemq.broker.jmx.ManagedTransportConnection.processAddConnection(ManagedTransportConnection.java:86)
        at
org.apache.activemq.command.ConnectionInfo.visit(ConnectionInfo.java:125)
        at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:282)
        at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:179)
        at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
        at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:134)
        at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:204)
        at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
        at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:196)
        at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:183)
        at java.lang.Thread.run(Thread.java:619)


This was done using spring 2.0 in a winXP box. does any one have an idea
about whats going on..
The same issue is there as a activemq bug report, but its in solved stage
for releases after 4.1
http://issues.apache.org/activemq/browse/AMQ-696
http://issues.apache.org/activemq/browse/AMQ-696 

Does anyone know what version of activemq we use in fuse message broker, it
seems to be version 5.0.
Does anyone have experinced this before and resolved it....? If yes How ?
:confused:

Thanks in advance..
 
-- 
View this message in context: http://www.nabble.com/client-already-connected-with-same-clientId-error-tp16494147s2354p16494147.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message