activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Miljour <mmilj...@idanalytics.com>
Subject Re: Consumers not always being released
Date Thu, 27 Mar 2008 01:02:12 GMT

Shared File System Master Slave does work for us.  I have attached a sample
of our config for one of the brokers below.

 <broker xmlns="http://activemq.org/config/1.0"
deleteAllMessagesOnStartup="true" dataDirectory="/data" persistent="true">

    <transportConnectors>
       <transportConnector name="openwire"
uri="tcp://host1:61616?wireFormat.maxInactivityDuration=0"/>
    </transportConnectors>

    <!-- The store and forward broker networks ActiveMQ will listen to -->
    <networkConnectors>
      <!-- Change this to include the URIs for each JMS server.  Do not use
a space around the comma or bad things will happen! -->
      <networkConnector name="HA Queue"
uri="static:(tcp://host1:61616,tcp://host2:61616)" />
    </networkConnectors>
 </broker>

i hope this helps,
Mike M


Ramit Arora wrote:
> 
> Hi,
> I am facing a problem setting up shared file system master slave on the
> latest 5.1 snapshot. The problems are mentioned in this thread 
> http://www.nabble.com/Shared-Filesystem-Master-Slave-doesn%27t-work-even-on-5.1-SNAPSHOT-td16315761s2354.html
> 
> Is master/slave working fine for you? Would you mind sharing your broker
> configs with me? Setting the same name for the two brokers does not seem
> to help in my case. 
> 
> Thanks,
> Ramit
> 

-- 
View this message in context: http://www.nabble.com/Consumers-not-always-being-released-tp15818936s2354p16320142.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message