activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Singer <Michal.Sin...@expand.com>
Subject Re: AUTO_ACKNOWLEDGE does not work, CLIENT_ACKNOWLEDGE works but not for temp queues
Date Thu, 20 Mar 2008 11:48:30 GMT

Hi. I am using the latest snapshot: apache-activemq-5.1-20080311.181016-59
Please note that the messages get stuck when i observe in jconsole the:
ActiveMQ.Advisory.TempQueue

But if i look specificly on a temp queue (before deleting it - the ack works
- after i updated to CLIENT_ACKNOWLEDGE )



rajdavies wrote:
> 
> 
> On 20 Mar 2008, at 07:14, Michal Singer wrote:
> 
>>
>> Hi.
>> I an using AUTO_ACKNOWLEDGE on a session, but the messages seem to  
>> be stuck
>> in the queue.
>> When i update to CLIENT_ACKNOWLEDGE + ack on each message, it works  
>> fine.
>> However, if i try the CLIENT_ACKNOWLEDGE + ack on messages delivered  
>> on temp
>> queues, it does not work.
>>
>> Does any one know why:
>> 1. AUTO_ACKNOWLEDGE  does not work?
>> 2. CLIENT_ACKNOWLEDGE does not work for temp queues?
>>
>> Thanks, Michal
>>
>> -- 
>> View this message in context:
>> http://www.nabble.com/AUTO_ACKNOWLEDGE-does-not-work%2C-CLIENT_ACKNOWLEDGE-works-but-not-for-temp-queues-tp16173331s2354p16173331.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
> Which version of activemq are you using ?
> 
> 

-- 
View this message in context: http://www.nabble.com/AUTO_ACKNOWLEDGE-does-not-work%2C-CLIENT_ACKNOWLEDGE-works-but-not-for-temp-queues-tp16173331s2354p16177070.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message