activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ttmdev <joe.fernan...@ttmsolutions.com>
Subject Re: Problem with SimpleAuthenticationPlugin
Date Sun, 02 Mar 2008 19:20:03 GMT

The default activemq.xml configuration file comes with three optional and
enabled elements: <commandAgent>, <camelContext>, and <jetty>.  If you
enable authentication & authorization services, these enabled elements will
cause the broker to throw security-related exceptions. This is because these
elements represent functionality that is essentially represented by clients
that need to connect to the broker and the connections are made without
security credentials.  If you do not require the functionality behind these
elements, disable or comment-out the elements. 

Joe
www.ttmsolutions.com


/U wrote:
> 
> 
> 
> I am using ActiveMQ5.0.0 and am using TCP transport with JRE1.6.
> 
> I am using a rudimentary form of authentication using
> SimpleAuthenticationPlugin
> as follows:
> 
>    <broker xmlns="http://activemq.org/config/1.0" brokerName="localhost"
> dataDirectory="${activemq.base}/data">
>        <plugins>
>          <simpleAuthenticationPlugin>
>             <users>
>                 <authenticationUser username="system" password="manager"
>                         groups="users,admins"/>
>            </users>
>         </simpleAuthenticationPlugin>
>       </plugins>
>      //...
> 
> When I start the broker, it aborts with the exception that the
> username/password is invalid.
> I have not event started my client to connect to the broker. What does
> this error mean?
> Is this reporting bad authentication credentials from a client or is it
> saying that the
> configured username/password is unacceptable?
> 
> 
> INFO  TransportServerThreadSupport   - Listening for connections at:
> tcp://thishost:61616
> INFO  TransportConnector             - Connector openwire Started
> WARN  TransportConnection            - Failed to add Connection
> java.lang.SecurityException: User name or password is invalid.
>         at
> org.apache.activemq.security.SimpleAuthenticationBroker.addConnection(SimpleAuthenticationBroker.java:52)
>         at
> org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:91)
>         at
> org.apache.activemq.broker.TransportConnection.processAddConnection(TransportConnection.java:657)
>         at
> org.apache.activemq.broker.jmx.ManagedTransportConnection.processAddConnection(ManagedTransportConnection.java:86)
> 
> 
> Regards
> 
> /Ur
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-with-SimpleAuthenticationPlugin-tp15784737s2354p15791827.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message