activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: ActiveMQ failover question
Date Fri, 22 Feb 2008 09:25:52 GMT

On 21 Feb 2008, at 21:57, rd7 wrote:

>
> Hello,
>
>  We are using ActiveMQ 4.1.1 and are in the process of testing  
> failover (we
> have only tested client failover so far).
>
>  We have 2 servers (host 1 & host2), each with 1 broker and 2  
> publishers
> each.  So, the 2 publishers that are on host1 send messages to the  
> broker on
> host1 and use host2 as failover, and vice versa for host2.
>
> There are 2 clients, each of which are deployed on different servers.
> Client 1 connects to host1 first (with host2 as failover) and vice- 
> versa for
> client 2.
>
>  If the broker on host1 goes down, the publishers on host1 and  
> client1 will
> failover to host2.  If the broker on host1 comes back up, is there a  
> way for
> the publishers on host1 and client1 to revert back automatically to  
> using
> the broker on host1 again?
>
> Here is the example of our URL:
>
> failover://(tcp://host1:61616,tcp://host2:61616)? 
> wireFormat 
> .maxInactivityDuration 
> =0&amp;initialReconnectDelay=100&amp;randomize=false
>
> Thanks for your help.
>
> -- 
> View this message in context: http://www.nabble.com/ActiveMQ-failover-question-tp15619364s2354p15619364.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Not currently - you can add this as a feature request - or contribute  
a patch ;)

cheers,

Rob

Mime
View raw message