activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Albert Strasheim <full...@gmail.com>
Subject Re: Session.recover() not working
Date Sat, 09 Feb 2008 09:42:49 GMT
Hello,

Did you ever resolve this issue? If not, please submit a JIRA issue with 
some sample code attached.

Regards,

Albert

On Fri, 14 Sep 2007, pfid wrote:

> 
> i'm using a 4.1.1 broker, and cms-2.1.1 clients as consumers/producers,
> working with queues, CLIENT_ACK mode.
> 
> i noticed some strange behaviour when the consumer is offline while the
> producer sends. for testpurpose i have the producer send 300 messages to
> some queue. i then start the consumer and start reading messages. at, say,
> message 100 i kill the consumer. upon restarting the consumer it wont
> however receive any more messages, although theres 200 more in the queue. i
> need to send 1 additional message from any producer, to trigger the message
> receiving on the consumer. the consumer can even be offline again - once
> theres an additional message in the queue, the consumer will resume
> receiving messages upon restarting.
> 
> ive searched the forums for hints on this problem, but found none. i found
> that redelivery with CLIENT_ACK connection is done with using the
> session.recover() method. however it seems like cms-2.1.1 doesnt have this
> method, at least it doesnt for me.
> 
> any ideas?
> -- 
> View this message in context: http://www.nabble.com/Session.recover%28%29-not-working-tf4442498s2354.html#a12675255
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> 

Mime
View raw message