activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From toli <t...@marketcetera.com>
Subject Re: ActiveMQ - Maven - ActiveIO
Date Thu, 28 Feb 2008 19:58:07 GMT

Jason, 

Including the snapshot repo worked for me until this morning, when it
started failing. Seems that the 3.1-SNAPSHOT is gone from the snapshot repo:
http://people.apache.org/repo/m2-snapshot-repository/org/apache/activemq/activeio/

Any thoughts on when (and if) it's coming back?

thanks.


Jason Anderson-3 wrote:
> 
> it really seems like if the project depends on a snapshot, the apache
> snapshot repository should be in the pom
> 
> as a workaround you can add it to your pom (or settings.xml or
> whatever) but it would be nice if this wasn't necessary
> 
> <repositories>
>         <repository>
>             <id>apache-snaps</id>
>             <name>apache snapshot repository</name>
>            
> <url>http://people.apache.org/repo/m2-snapshot-repository</url>
>             <releases>
>                 <enabled>false</enabled>
>             </releases>
>             <snapshots>
>                 <enabled>true</enabled>
>             </snapshots>
>         </repository>
> </repository>
> 
> 
> On Dec 19, 2007 10:34 AM, Geoffrey Wiseman <geoffrey.wiseman@gmail.com>
> wrote:
>> I wanted to take a quick look at ActiveMQ's latest version, so I fired up
>> a
>> quick maven project, added the dependency that was listed on the ActiveMQ
>> website, and ran a "mvn eclipse:eclipse".
>>
>> Sadly:
>>
>> > [WARNING] An error occurred during dependency resolution.
>> >     Failed to retrieve org.apache.activemq:activeio-core-3.1-SNAPSHOT
>> > Caused by: Unable to download the artifact from any repository
>> >
>> > Try downloading the file manually from the project website.
>> >
>> > Then, install it using the command:
>> >     mvn install:install-file
>> -DgroupId=org.apache.activemq-DartifactId=activeio-core -Dversion=
>> > 3.1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>> >
>> > Alternatively, if you host your own repository you can deploy the file
>> > there:
>> >     mvn deploy:deploy-file
>> -DgroupId=org.apache.activemq-DartifactId=activeio-core -Dversion=
>> > 3.1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url]
>> > -DrepositoryId=[id]
>> >
>> > Path to dependency:
>> >         1) com.feedroom.spike.activemq:activemq-spike:jar:1.0-SNAPSHOT
>> >         2) org.apache.activemq:activemq-core:jar:5.0.0
>> >         3) org.apache.activemq:activeio-core:jar:3.1-SNAPSHOT
>> >
>> >
>> >   org.apache.activemq:activeio-core:jar:3.1-SNAPSHOT
>> >
>> > from the specified remote repositories:
>> >   apache.snapshots
>> (http://people.apache.org/repo/m2-snapshot-repository),
>> >   apache.incubating.releases (
>> > http://people.apache.org/repo/m2-incubating-repository),
>> >   central (http://repo1.maven.org/maven2)
>> >
>> > [INFO] Unable to read jar manifest from
>> >
>> C:\dev\tools\m2_repo\org\apache\activemq\activeio-core\3.1-SNAPSHOT\activeio-
>> > core-3.1-SNAPSHOT.jar
>> > Downloading:
>> >
>> http://spatium/artifactory/repo/org/apache/geronimo/specs/geronimo-j2ee-management_1.0_spec/1.0/geronimo-j2ee-management_1.0_spec-1.0.jar
>> > 15K downloaded
>> > Downloading:
>> >
>> http://spatium/artifactory/repo/org/apache/activemq/activeio-core/3.1-SNAPSHOT/activeio-core-3.1-SNAPSHOT-tests.jar
>> > Downloading:
>> >
>> http://spatium/artifactory/repo/org/apache/activemq/activeio-core/3.1-SNAPSHOT/activeio-core-3.1-SNAPSHOT-tests.jar
>> > [WARNING] An error occurred during dependency resolution.
>> >     Failed to retrieve org.apache.activemq:activeio-core-3.1-SNAPSHOT
>> > Caused by: Unable to download the artifact from any repository
>> >
>>
>> After a quick check, it seems like I was able to verify Maven's
>> complaint:
>>
>>    - ActiveMQ's POM (activemq-core + activemq-parent) depends on
>>    org.apache.activemq:activeio-core:jar:3.1-SNAPSHOT
>>    - There's no org/apache/activemq/activeio-core in the M2 repo.
>>
>> I did a quick Nabble search, didn't immediately find anyone with this
>> problem (although some messages seemed to imply that activeio was
>> optional,
>> and others imply that it's been missing from the maven repo for a while;
>> finally, another suggested that depending on a SNAPSHOT from a release
>> was
>> perhaps a bad idea, which I'm inclined to agree with).
>>
>> Suggestions?
>>
>>   - Geoffrey
>> --
>> Geoffrey Wiseman
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ---Maven---ActiveIO-tp14422739s2354p15744415.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message