activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wha <willy...@cgi.com>
Subject Re: Consumer not consuming messages
Date Tue, 12 Feb 2008 22:40:52 GMT

I can't see your entire code.

I don't know if you have a setMessageListener(YourConsumerClass) for your
consumer.

Your consumer class must implement MessageListener.




Jeroen van Bergen wrote:
> 
> 
> 
>>>> The producer is happily producing messages. I can browse them using the
>>>> web
>>>> front end supplied with ActiveMQ. When I add a QueueBrowser to the
>>>> consuming
>>>> class it can see the messages in the queue. The consumer is not picking
>>>> up
>>>> any message at all.
>> 
>>>Have you hit this FAQ entry?
>>>http://activemq.apache.org/i-am-not-receiving-any-messages-what-is-wrong.html
>> 
> Thanks for the hint. However, the connection was started. Relevant code:
> QueueConnectionFactory connectionFactory = new
> ActiveMQConnectionFactory(url);
> Connection connection = connectionFactory.createConnection();
> session = connection.createSession(false, Session.CLIENT_ACKNOWLEDGE);
> consumer = session.createConsumer(session.createQueue(queueName));
> connection.start();
> 
> I'm still very confused why a QueueBrowser can see messages in the queue
> while a Consumer does not pick up any. The ActiveMQ logfile shows nothing
> special. Anything else I can look at?
> 

-- 
View this message in context: http://www.nabble.com/Consumer-not-consuming-messages-tp15411975s2354p15444805.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message