activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Rosenberg <jrosenb...@shopzilla.com>
Subject Re: Sent + Pending should equal Received, no?
Date Sun, 10 Feb 2008 09:09:47 GMT

Ok,

I enabled DEBUG logging on the broker, and now I see this on restart:

2008-02-10 03:52:43,645 [127.0.0.1:64511] DEBUG RecoveryListenerAdapter       
- Message id ID:szjrosenberg-mbp17.local-64382-1202633445267-0:22:1:1:1
could not be recovered from the data store - already dispatched

In fact, I see 8 of these, and the webconsole in this case now shows '8'
pending messages for the queue, but never delivers them.  The webconsole
showed 0 pending messages before shutting down, etc...

I guess there are 2 issues.  First, if it can't recover the message, it
probably shouldn't show it as pending.   Second, need to find out why it's
even trying to recover the message in the first place, after showing no
Pending message before shutdown.

I'm using a 5.1-SNAPSHOT broker that I downloaded around Jan 24, 2008....

Jason



Jason Rosenberg wrote:
> 
> Now, after closing down all connected clients, and restarting the broker,
> the webconsole shows the same queue has 2 pending messages....Clicking on
> browse messages shows no messages.....
> 
> I'm wondering if the jmx QueueViewMBean needs to have more refinement to
> display more detailed status of messages that are in various states (e.g.
> cached, redelivered, recovered, rolled-back, etc.)...
> 
> Or is it likely a bug altogether...
> 
> Fun stuff
> 
> Jason
> 
> 
> 
> Jason Rosenberg wrote:
>> 
>> I just tried clicking on "purge" in the webconsole, on a queue that
>> seemed to have messages stuck in the pending state.  After the purge, it
>> now shows that it has -4 messges pending.
>> 
>> Should it ever be a negative number of messages pending?
>> 
>> Jason
>> 
>> 
>> 
>> 
>> Jason Rosenberg wrote:
>>> 
>>> I have a scenario, with amq 5.1....
>>> 
>>> Where more messages are being received than are sent.  Should that be
>>> possible?  It looks like indeed some of the messages are getting
>>> delivered twice, and tallied as such in the webconsole view of the
>>> queue....Is there some setting I need to place on my queues to make sure
>>> this doesn't happen?  Or is it a bug...
>>> 
>>> I'm using the amqPersistence for persistent messaging.
>>> 
>>> Also, see my previous post, regarding the broker showing new messages
>>> Pending after restarting the broker....
>>> 
>>> Weirdness, it would seem....
>>> 
>>> The config is very much the same as what I had previously with 4.1.1,
>>> using the default persistence there (journaled file-based jdbc)....
>>> 
>>> Jason
>>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Sent-%2B-Pending-should-equal-Received%2C-no--tp15367886s2354p15394557.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message