activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: ActiveMQ Slave loops for lock, preventing JBoss to continue deployment
Date Fri, 04 Jan 2008 21:09:39 GMT
Yep we have an issue open about it already:

http://issues.apache.org/activemq/browse/AMQ-1519

On Jan 3, 2008 3:41 PM, aarvee <rvenkataraman@coremobility.com> wrote:
>
> I have embedded ActiveMQ 5.0.0 (with Master-Slave Shared File System config.)
> in JBoss using the suggested RAR approach.
>
> I am using two JBoss instances in a JBoss HA Cluster.
> The first JBoss instance (with ActiveMQ Master) comes up fine.
>
> However on start, the second JBoss instance does not complete deployment
> because the ActiveMQ Slave is forever looping to get the Shared File System
> lock.
>
>     "org.apache.activemq.store.journal.JournalPersistenceAdapterFactory -
> Journal is locked... waiting 10 seconds for the journal to be unlocked"
>
> Is there a way this looping check be in a background thread, so that other
> Jboss deployed components like EJBs, MBeans, Servlets etc. can come up ?
>
> In our configuration, only the JMS Q is HA Master-Slave; the other
> components are Active-Active.
>
> Thanks for any help !
>
> P.S.  The Message Groups feature is awesome. Thanks !
>
>
>
>
>
>
> --
> View this message in context: http://www.nabble.com/ActiveMQ-Slave-loops-for-lock%2C-preventing-JBoss-to-continue-deployment-tp14604762s2354p14604762.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>



-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Open Source SOA
http://open.iona.com

Mime
View raw message