activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: AdvisoryBroker consumerCount incorrect
Date Mon, 14 Jan 2008 11:04:52 GMT

On Jan 14, 2008, at 10:47 AM, joe.stapleton wrote:

>
>
> rajdavies wrote:
>>
>> Hi Joe,
>>
>> this looks like an issue - will look at fixing
>>
>> thanks,
>>
>> Rob
>>
>>
>
> In the mean time i'm going to try and use jmx to determine when a  
> queue has
> no subscribers. Now we are running a multiple brokers. Connecting to  
> an
> individual broker the consumerCount on a destination seems to  
> reflect the
> directly connected consumer count plus the number of brokers which  
> also have
> consumers for that destination. Is it correct to assume that when  
> there are
> no real (non broker) consumers that this count will drop to zero,  
> i.e. will
> the other brokers close their consumers when they have no direct  
> consumers
> themselves? I have dynamicOnly=true on the network connector.
>
> I'm asking this since I would want to avoid falsly believing there  
> to be
> consumers for a destination when in actual fact there are just a  
> bunch of
> brokers consuming from each other.
>
> Cheers,
>
> Joe

Yes - this is correct if dynamicOnly=true
>
>
> -- 
> View this message in context: http://www.nabble.com/AdvisoryBroker-consumerCount-incorrect-tp14759255s2354p14798623.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


Mime
View raw message