activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DaveKant <DK...@cantorindex.co.uk>
Subject Remote JMX in AMQ 5.0.0
Date Thu, 24 Jan 2008 13:25:51 GMT

I've tried connecting to remote JMX but have not been able to do this
successfully using jconsole and AMQ 5 on the Solaris 10 platform. I've
looked through various postings to this site and the activemq jmx page but
still have problems.
   http://activemq.apache.org/jmx.html
  
http://www.nabble.com/jmx-remote-not-working-to13252442s2354.html#a13290654

Here is what I've done:

1. Modified broker in active.xml
    <broker xmlns="http://activemq.org/config/1.0" brokerName="localhost"
useJmx="true" dataDirectory="${activemq.base}/data>

2. Modified managementContext in activemq.conf to disable JMX connector

    <managementContext>
       <managementContext createConnector="false" />
    </managementContext>

3. Modified SUNJMX in bin/activemq 
   -Dcom.sun.management.jmxremote=true 
   -Dcom.sun.management.jmxremote.authenticate=false 
   -Dcom.sun.management.jmxremote.ssl=false 
   -Dcom.sun.management.jmxremote.port=1616 

Other things I've tried:-
1. Changed the JMX port (e.g 1099, 1616)
2. Used a port scanner to verify that the remote port is open after activemq
has started
3. Tried an alternative approach where

    <managementContext>
       <managementContext connectorPort="1616"
jmxDomainName="org.apache.activemq"/>
    </managementContext>

 and SUNJMX 

   -Dcom.sun.management.jmxremote 
   -Dcom.sun.management.jmxremote.authenticate=false 
   -Dcom.sun.management.jmxremote.ssl=false 

Uisng this approach AMQ startup reports:-
INFO ManagementContext JMX consoles can connect to
service:jmx:rmi:///jndi/rmi://localhost:1616/jmxrmi
  
However, all these attempts still result in a connection failed.

Thanks, Dave

-- 
View this message in context: http://www.nabble.com/Remote-JMX-in-AMQ-5.0.0-tp15063754s2354p15063754.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message