activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: QueueSize attribute
Date Mon, 03 Dec 2007 11:14:35 GMT
That sounds like a bug - the counter should be reset on restart once
the queue is being used again.

On 03/12/2007, Viswanath Durbha <Viswanath.Durbha@gmail.com> wrote:
>
> Hi,
>
> This question is regarding the QueueSize attribute of a queue in a
> persistent broker.
>
> I'm using ActiveMQ 5.0 snapshot version. I have a broker called broker1
> queue called test.queue. The broker has persistence enabled and it is using
> the default AMQ storage adapter. I sent some messages to this queue using
> the web console. I checked the 'Persistent Delivery' checkbox on the form
> for sending the message. There are no consumers for this message. So the
> message stays in the queue. The web console shows the "Number of Pending
> Messages" as 1.
>
> I bounce back the broker and then refresh my web console. Now the "Number of
> Pending Messages" column shows zero. But when I browse the queue, the
> message is listed. The JMX console also shows the QueueSize of the
> 'test.queue' as zero even though there is a message in the queue.
>
> Can someone help me to figure out how the QueueCount attribute works and
> whether this is expected behavior or a bug?
>
> Thanks,
> Viswanath
> --
> View this message in context: http://www.nabble.com/QueueSize-attribute-tf4935791s2354.html#a14127843
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
James
-------
http://macstrac.blogspot.com/

Open Source Integration
http://open.iona.com

Mime
View raw message