activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: Delphi STOMP client does not receive all messages
Date Sat, 15 Dec 2007 18:44:30 GMT
You might want to submit a test case that we can review and try out.

On Dec 15, 2007 8:01 AM, mjustin <michael.justin@gmx.net> wrote:
>
> Hello!
>
> Currently I am developing a Delphi / Free Pascal STOMP client for ActiveMQ.
> Connecting, subscribing, sending and transaction support works very well.
>
> However, if I send a high number of messages to the client in a short time
> (using the ActiveMQ Web Console for exmple, but I have also tested the STOMP
> client from Codehaus), some of the messages will not appear in the client.
> My STOMP client uses blocking or nonblocking communication, depending on the
> underlying communication library, with the same results.
>
> In the ActiveMQ Console, the values "Messages Sent" and "Messages Received"
> are equal, so it looks like ActiveMQ has not encountered any problems with
> the message transfer to the client.
>
> I also tried version 5 and 4.1 of ActiveMQ, with automatic and client-side
> acknowledgement of the messages, with the same results.
>
> My hope is that there is very simple reason for undelivered messages - maybe
> it is just an operating system issue (Windows XP with all service packs).
>
> Any help would be very appreciated
>
> Michael Justin
>
>
>
> --
> View this message in context: http://www.nabble.com/Delphi-STOMP-client-does-not-receive-all-messages-tp14350635s2354p14350635.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>



-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Open Source SOA
http://open.iona.com

Mime
View raw message