activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: Memory Leak?
Date Fri, 14 Dec 2007 19:09:21 GMT
What amq version jdk and os?  Also is it the client or the broker that
gets the OOM?

On Dec 7, 2007 12:19 PM, Alan Williamson <alan@blog-city.com> wrote:
> All,
>
> We are using ActiveMQ v5, and have found an interesting situation with
> our sending process.
>
> We have just confirmed, that if we turn off the sending, then the
> process stays up, all day no problems.  If we turn on the broadcasting,
> then we get OutOfMemory errors within a few hours.
>
> We sending around 3,000 MapMessage's per hour.   We are sending them to
> a temporary topic (one we create on startup, but it is the same name
> everytime).
>
> We use the code here to broadcast:
>    http://clients.aw20.net/whiteboard/?b=19312
>
> Nothing at all out of the ordinary.  The maps themselves are not at all
> huge, just a bunch of small string values.
>
> So, questions
>
> 1. Is there any special switches we need to do?  We see the
> "optimizeAcknowledge" is defaulted to false already
>
> 2. As you can see, we create a Topic/Session on each call, should we not
> be doing that and instead reusing the instance?
>
>
> thank you for any assistance
>
> alan
>
>
> --
> Alan Williamson
>   "a wiki -and- a blog" @ http://www.Blog-City.com/
>
>   b: http://alan.blog-city.com/
>



-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Open Source SOA
http://open.iona.com

Mime
View raw message