activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: Network of Broker with different versions (3-4, 4-5)?
Date Fri, 14 Dec 2007 17:57:09 GMT
The general anwser is no.  ActiveMQ has only traditionally maintained
wire protocol compatibility between clients and brokers in the same
major release.  But the wire protocol in ActiveMQ 4 introduced
versioning which allows the possibility to support backward
compatibility.  Testing has shown that ActiveMQ 4 client are able to
talk to ActiveMQ 5 brokers.  And in theory ActiveMQ 4 and 5 brokers
should therefore also be able to establish network connections between
each other but this has not been highly tested.

If you guys do test this out please report your results.

Regards,
Hiram

On Dec 14, 2007 8:00 AM, Michael40 <michael.enke@wincor-nixdorf.com> wrote:
>
> Hello,
> is it possible to have inter broker communication between ActiveMQ of
> different
> major number releases?
> I tried between 3.2.2 and 4.1.1 but I got:
> javax.jms.JMSException: start failed: Read timed out at the 3.2.2 and
> java.io.IOException: Wire format negociation timeout: peer did not send his
> wire format at the 4.1.1 broker.
>
> I have read that using ServiceMix it is possible to bridge different JMS
> broker.
> Do I have to deploy ServiceMix if I want to have communication between
> ActiveMQ 3 and 4?
>
> Regards,
> Michael
> --
> View this message in context: http://www.nabble.com/Network-of-Broker-with-different-versions-%283-4%2C-4-5%29--tp14335445s2354p14335445.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>



-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Open Source SOA
http://open.iona.com

Mime
View raw message