activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kapilanand <>
Subject ServerSessionMessageListenerContainer does not failover
Date Mon, 31 Dec 2007 18:47:33 GMT

I am using ActiveMQ 5.0 with Spring 2.0.7 and I am using ActiveMQ schema
based xbeans.

<beans xmlns=""

I have a cluster of brokers configured as peers via the common discoveryUrl.
All these brokers individually provide tcp interface. These brokers are
configured within the JVMs of the producers. (Using Spring xbean
configuration again).

Consumer clients use activemq connection factory based on a failover URL.
This failover URL is comprised of a list of the clusterred brokers: 

I am using amq:connectionFactory XML element to define the connection
factory objects in producer and consumer configuration. (I believe this maps
to org.apache.activemq.ActiveMQConnectionFactory)

I tried DefaultMessageListenerContainer  and
ServerSessionMessageListenerContainer and the configuration for both was
identical. (connectionfactory reference, destination reference and
messagelistener reference)

The failover works perfectly with DefaultMessageListenerContainer but does
not work when I use ServerSessionMessageListenerContainer.

On the consumer side, do I need to setup connectionfactory in a different
way when using ServerSessionMessageListenerContainer?

Do I need special configuration of ServerSessionMessageListenerContainer
itself for failover to work?

Do I need to setup brokers in a specific way to enable support for
ServerSession SPI support?

thanks for your help
View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message