activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From amaas <am...@proofpoint.com>
Subject Re: ActiveMQ thoughts
Date Wed, 26 Dec 2007 18:33:12 GMT

I wish I could provide that. The problem happen on our production site and
only after about an hour of running. I managed to reproduce it once on test
machine after many tries. I had to create many publishers and many
consumers. On production mahcine it always happen (but at random times).

It seems like a race condition that happen by chance. More chance of it
happening in a busy deployment with many read/writes to the same queue.

Andy


rajdavies wrote:
> 
> If you experience problems - the best thing to do is to raise a  
> support issues (jira) , with a junit test case (hopefully one class -  
> look at the src for examples) asap
> Provide details about your environment, the version of AMQ you are  
> running and any config information as well.
> 
> cheers,
> 
> Rob
> 
> On Dec 22, 2007, at 5:33 AM, amaas wrote:
> 
>>
>> I watch this thread with interest because I also have issues with  
>> activemq
>> and have not found any solution (using released version 5.0). I kind  
>> of lost
>> hope right now with using activemq.
>>
>> I use Stomp for publisher and consumer. There are about 30 producers  
>> and 40
>> consumers each using their own connection. Traffic is only about a  
>> couple
>> per second with avg size of 500M.
>>
>> 1) Using AMQ storage, I experienced consumers block waiting for msgs  
>> when
>> there are msgs in the store and publisher submitting without  
>> problem. This
>> usually happens after half an hour or an hour after deployment.  
>> Restarting
>> activemq would fix the problem once (subsequent restart seems to  
>> lost all
>> msgs; the first restart showing 0 msg count despite non zero msg in  
>> the
>> queue)
>> This error coincide with the blockage:
>>
>> 2007-12-12 19:38:02,597 [0.31.1.20:46277] ERROR  
>> RecoveryListenerAdapter
>> - Message id ID:prs2005-35745-1197487997180-4:28:-1:1:4 could not be
>> recovered from the data store!
>>
>> 2) I then switch to use Kaha storage. The same problem occured.
>>
>> 3) I then try journaledJDBC with derby. I observed a different  
>> problem. I
>> saw errors and for each error I lost the msg. So while I was happier  
>> that
>> activemq didn't stop, I lost messages instead. The error in the log:
>>
>> 2007-12-19 17:00:09,826 [eckpoint worker] ERROR TransactionTemplate
>> - Having to Rollback - caught an exception: java.io.IOException: A
>> truncation error was encountered trying to shrink BLOB 'XX-RESOLVE- 
>> XX' to
>> length 1048576.
>>
>> 4) I then try journaledJDBC with mysql. Right away I got duplicate  
>> key error
>> on injection. This is becuase I use virtual topic. Apparently for each
>> message there are two INSERT using the same record id. So I switch to
>> regular queue. This time I started seeing this error in the log:
>>
>> 2007-12-20 15:31:45,878 [eckpoint Worker] ERROR  
>> JournalPersistenceAdapter
>> - Failed to checkpoint a message store:
>> java.util.concurrent.ExecutionException: java.io.IOException: Already
>> started
>>
>> I am really hoping I can use activemq with amq store (don't want to  
>> extra db
>> server to manage).
>> But I just can't get it to work cleanly for me.
>> -- 
>> View this message in context:
>> http://www.nabble.com/ActiveMQ-thoughts-tp14262131s2354p14466561.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ-thoughts-tp14262131s2354p14504909.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message