activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lephix <lep...@163.com>
Subject a error occured at Networks of broker when reconnecting
Date Thu, 20 Dec 2007 10:55:36 GMT

there are two Brokers in two machines.
IP are 192.9.105.141, 192.9.105.142
i use networkConnectors to make two Brokers together.
i can start both of they well.
but when one of Brokers dies, i got the message like that:

WARN  TransportConnection            - Unexpected extra broker info command
rece
ived: BrokerInfo {commandId = 7, responseRequired = false, brokerId =
ID:vmwin20
03pure-1645-1198146771812-1:0, brokerURL = tcp://vmwin2003pure:61616,
slaveBroke
r = false, masterBroker = false, faultTolerantConfiguration = false,
networkConn
ection = false, duplexConnection = false, peerBrokerInfos = [], brokerName =
MQ0
1007000000000000000, connectionId = 0}

and only the restarted Broker could get the message from non-stop Broker.
the non-stop one could not receiver messages from restarted Broker.
two machines' ACTIVEMQ.XML like these:

===================SERVER1 XML========================
<beans>
  <bean
class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
  <broker brokerName="MQ01007040000000000000" useJmx="false"
persistent="true" xmlns="http://activemq.org/config/1.0">
    <persistenceAdapter>
        <journaledJDBC journalLogFiles="5"
dataDirectory="${activemq.base}/activemq-data"/>
    </persistenceAdapter>
    <transportConnectors>
       <transportConnector name="TCP01007040000000000000"
uri="tcp://localhost:61616" discoveryUri="multicast://default"/>
    </transportConnectors>
    <networkConnectors>	  
	<networkConnector name="MQ01007000000000000000"
uri="static://(tcp://192.9.105.141:61616)" failover="true"/>
    </networkConnectors>
  </broker>
</beans>

=========================SERVER2 XML============================
<beans>
  <bean
class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
  
  <broker brokerName="MQ01007000000000000000" useJmx="false"
persistent="true" xmlns="http://activemq.org/config/1.0">
    <persistenceAdapter>
        <journaledJDBC journalLogFiles="5"
dataDirectory="${activemq.base}/activemq-data"/>
    </persistenceAdapter>
  
    <transportConnectors>
       <transportConnector name="TCP01007000000000000000"
uri="tcp://localhost:61616" discoveryUri="multicast://default"/>
    </transportConnectors>
    
    <networkConnectors>      <networkConnector name="MQ01007040000000000000" 
	  uri="static://(tcp://192.9.105.142:61616)" failover="true"/>
    </networkConnectors>
  </broker>
</beans>
==================================OVER=======================================

who can help me? 
thanks~~~
-- 
View this message in context: http://www.nabble.com/a-error-occured-at-Networks-of-broker-when-reconnecting-tp14434305s2354p14434305.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message