activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From QWERTY? <qwerty...@gmail.com>
Subject Re: unable to lookup a topic
Date Thu, 20 Dec 2007 02:01:39 GMT

aahhh ok excellent, i just need to add those to the properties i pass into my
initial context, and it works fine.

Cheers,


ttmdev wrote:
> 
> See this  AMQ web page
> 
> http://activemq.apache.org/jndi-support.html
> 
> If you're running a standalone java app, then the jndi.properties file is
> what you're looking for. There is a very simple example of one in the
> above page. 
> 
> Joe
> 
> 
> 
> QWERTY? wrote:
>> 
>> Ok just as a disclaimer Im having alot of trouble setting up ActiveMQ,
>> because the documentation isnt that flash, but it appears it will do what
>> i need it to do.. if i could get it to work..
>> 
>> So im trying to do two things, setup Queue's and Topic's in my config so
>> when ActiveMQ starts it will have the queue/topics already defined
>> Also for Queue's I need to be able to retain unrecieved messages if
>> ActiveMQ is to go down, and they should be delivered once amq is up and a
>> client is there to recieve it.
>> 
>> I cant really seem to figure out how to setup the queue/topics properly
>> in my config xml i have setup the following 
>> 
>>     <destinations>
>>       <queue physicalName="testqueue" />
>>       <topic physicalName="testtopic" />
>>     </destinations>
>> 
>> both of these show up fine when i look in the web monitor, but from my
>> client I cannot look them up, is there a JNDI setup somewhere i need to
>> change? 
>> 
>> I can setup dynamic queues/topics so i know i can actually send/recieve
>> messages through activeMQ
>> 
>> any help is appreciated.
>> 
>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/unable-to-lookup-a-topic-tp14428726s2354p14429351.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message