activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OLF <o...@afrika-virus.de>
Subject Distributed commons-collections does not contain a required class
Date Fri, 07 Dec 2007 13:10:17 GMT

Hi,

i'm using AMQ 4.1.1 in an embedded broker.

During startup there is a DEBUG message java.lang.ClassNotFoundException:
org.apache.commons.collections.map.LinkedMap.
 
The lib/optional folder of the AMQ directory is on the classpath, BUT
version 2.1 of commons-collections, which comes with AMQ does not contain a
package org.apache.commons.collections.map. 
Version 3.1 of commons-collections does. Wrong version delivered ?

2007-12-07 13:52:52,294 [main           ] INFO  BrokerService                 
- ActiveMQ JMS Message Broker (localhost,
ID:pdbh843a.olf.de-59706-1197031952036-0:0) stopped
13:52:55 INFO  JDK 1.4+ collections available
2007-12-07 13:52:55,775 [main           ] INFO  CollectionFactory             
- JDK 1.4+ collections available
13:52:55 DEBUG Class [org.apache.commons.collections.map.LinkedMap] or one
of its dependencies is not present: java.lang.ClassNotFoundException:
org.apache.commons.collections.map.LinkedMap
2007-12-07 13:52:55,778 [main           ] DEBUG ClassUtils                    
- Class [org.apache.commons.collections.map.LinkedMap] or one of its
dependencies is not present: java.lang.ClassNotFoundException:
org.apache.commons.collections.map.LinkedMap

Regards

OLF
-- 
View this message in context: http://www.nabble.com/Distributed-commons-collections-does-not-contain-a-required-class-tf4961999s2354.html#a14212237
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message