activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pfid ...@informationsdesign.de>
Subject Re: Building ActiveMQ CPP on Solaris 10
Date Thu, 06 Dec 2007 09:23:52 GMT

I've had similar problems, and i found it was caused by an outdated tar
version, extracting some cpp files to *.cp instead of *.cpp, or *.h to *.
renaming the broken filenames fixed the problem for me.


Tim Bish wrote:
> 
> Have you checked the src directory to see if that file was really 
> there?  Solaris has any number of problems including their tar not 
> always extracting things tar'd by gnu tar.
> 
> Regards
> Tim.
> 
> bozimmerman wrote:
>> >From the solaris 10 x86 machine I was handed, the following steps were
>> taken:
>> Installed M4-1.4 (1.4.1 was a total waste of time :/ )
>> Installed LibTool 1.5.24
>> Installed cppunit 1.12.0
>> Installed Autoconf 2.61
>> Installed Automake 1.10
>>  -- all the above brings the it to ActiveMQ 2.1.1 tool specs
>> For those interested, the following extra steps were required:
>> LD_LIBRARY_PATH=/lib:/usr/local/lib
>> PATH=$PATH:/usr/ccs/bin
>>
>> Doing the above allowed autogen.sh to run GOOD.
>> Configure did it's thing and didn't fall short.
>> Make, however, pukes with the following:
>>
>>  g++ -DHAVE_CONFIG_H -I. -I../.. -ansi -pedantic -W -Wall -fPIC
>> -fstrict-aliasing -Wstrict-aliasing=2 -Wno-long-long -g -O2 -MT
>> activemq/connector/openwire/commands/libactivemq_cpp_la-XATransactionId.lo
>> -MD -MP -MF
>> activemq/connector/openwire/commands/.deps/libactivemq_cpp_la-XATransactionId.Tpo
>> -c activemq/connector/openwire/commands/XATransactionId.cpp -o
>> activemq/connector/openwire/commands/libactivemq_cpp_la-XATransactionId.o
>>   
>>> /dev/null 2>&1
>>>     
>> mv -f
>> activemq/connector/openwire/commands/.deps/libactivemq_cpp_la-XATransactionId.Tpo
>> activemq/connector/openwire/commands/.deps/libactivemq_cpp_la-XATransactionId.Plo
>> make[2]: *** No rule to make target
>> `activemq/connector/openwire/marshal/v1/ActiveMQBytesMessageMarshaller.cpp',
>> needed by
>> `activemq/connector/openwire/marshal/v1/libactivemq_cpp_la-ActiveMQBytesMessageMarshaller.lo'.

>> Stop.
>> make[2]: Leaving directory
>> `/export/home/bzimmerman/activemq-cpp-2.1.2-src/src/main'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory
>> `/export/home/bzimmerman/activemq-cpp-2.1.2-src'
>>
>> Any advice is appreciated...
>>
>>   
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Building-ActiveMQ-CPP-on-Solaris-10-tf4946243s2354.html#a14188828
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message