activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Unable to create MessageProducer
Date Mon, 12 Nov 2007 14:38:21 GMT
Without more information on how you are using the JMS client its hard
to know really. It could just be the socket has been dropped.

You night wanna enable failover...
http://activemq.apache.org/how-can-i-support-auto-reconnection.html

On 10/11/2007, TOPPER_HARLEY <TREVOR.HIGGINS@ericsson.com> wrote:
>
> Hi,
> Using AMQ4.1, non persistent, non transactional, I am running an embedded
> broker with Spring and am often getting an exception when trying to send a
> message:
>
>  java.io.IOException: The transport is not running.
>         at
>
> org.apache.activemq.transport.TransportSupport.checkStarted(TransportSupport.java:103)
>         at
>
> org.apache.activemq.transport.tcp.TcpTransport.oneway(TcpTransport.java:117)
>         at
>
> org.apache.activemq.transport.InactivityMonitor.oneway(InactivityMonitor.java:141)
>         at
>
> org.apache.activemq.transport.TransportFilter.oneway(TransportFilter.java:80)
>         at
>
> org.apache.activemq.transport.WireFormatNegotiator.oneway(WireFormatNegotiator.java:93)
>         at
>  org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:43)
>         at
>
> org.apache.activemq.transport.ResponseCorrelator.oneway(ResponseCorrelator.java:60)
>         at
>
> org.apache.activemq.ActiveMQConnection.asyncSendPacket(ActiveMQConnection.java:1151)
>
> I create one connection on startup and reuse that to create a session and
> message produer when trying to send a message. Is usually happens when I try
> to create a session or message producer. Sometimes even restarting the
> entire JVM does not fix the issue! Why would the transport be stopped....is
> there some background thread keeping it alive that maybe cannot get
> processor time to ping it if there is load?
>
> My XML defines one transport connector of the form
> tcp://localhost:61616?wireFormat.maxInactivityDuration=0
>
> What can I do to workaround this issue? Can I catch the exception and try to
> restart the tranport somehow, although that feels like a bad solution? If I
> switched to a "vm:" style URI would it make it easier to keep transport
> alive?
>
> Any help is much appreciated as this has us stumped...
>
> /Tom
>
> --
> View this message in context: http://www.nabble.com/Unable-to-create-MessageProducer-tf4782623s2354.html#a13682284
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
James
-------
http://macstrac.blogspot.com/

Open Source SOA
http://open.iona.com

Mime
View raw message