activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher.Mathru...@sybase.com
Subject Re: Unable to build 5.0 source
Date Tue, 06 Nov 2007 19:46:52 GMT

<br><font size=2 face="sans-serif">I found the solution. It seems there
was something odd about my maven repository (.m2/repository). I'm not certain
what but I simply depleted it, cleaned the source directory and performed
a build. Surprisingly everything worked this time.</font>
<br><font size=2 face="sans-serif"><br>
Chris Mathrusse<br>
christopher.mathrusse@sybase.com<br>
Sybase, Inc<br>
One Sybase Drive<br>
Dublin, CA 94568<br>
(925) 236-5553</font>
<br>
<br>
<br>
<table width=100%>
<tr valign=top>
<td width=40%><font size=1 face="sans-serif"><b>Christopher.Mathrusse@sybase.com</b>
</font>
<p><font size=1 face="sans-serif">11/06/2007 11:08 AM</font>
<table border>
<tr valign=top>
<td bgcolor=white>
<div align=center><font size=1 face="sans-serif">Please respond to<br>
users@activemq.apache.org</font></div></table>
<br>
<td width=59%>
<table width=100%>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">To</font></div>
<td><font size=1 face="sans-serif">users@activemq.apache.org</font>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">cc</font></div>
<td>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">Subject</font></div>
<td><font size=1 face="sans-serif">Re: Unable to build 5.0 source</font></table>
<br>
<table>
<tr valign=top>
<td>
<td></table>
<br></table>
<br>
<br>
<br><font size=2 face="sans-serif"><br>
This error seems to be associated to the <i>activemq-tooling</i> project.
By removing this project from the pom.xml residing in the parent directory
I was able to successfully get the project to compile. I did need to modify
the MAVEN_OPTS beyond what was specified on the build page to the following:</font><font
size=3>
<br>
</font><font size=2 face="sans-serif"><br>
MAVEN_OPTS=-Xmx1024m</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
A value of 800 seemed to be insufficient as I repeatedly was seeing an
Out Of Memory error. By increasing the value to 1024 the project was able
to compile without error. But it makes me wonder if I am missing out on
any significant functionality by removing the <i>activemq-tooling</i> project
from the build. Will this have an impact on how ActiveMQ operates? If so,
is there any way to repair the build?\</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
Thanks...</font><font size=3> </font><font size=2 face="sans-serif"><br>
<br>
Chris Mathrusse</font><font size=3><br>
<br>
<br>
</font>
<table width=100%>
<tr valign=top>
<td width=53%><font size=1 face="sans-serif"><b>Christopher.Mathrusse@sybase.com</b>
</font>
<p><font size=1 face="sans-serif">11/05/2007 12:36 PM</font><font size=3>
</font>
<br>
<table border=4 width=100%>
<tr valign=top>
<td width=100% bgcolor=white>
<div align=center><font size=1 face="sans-serif">Please respond to<br>
users@activemq.apache.org</font></div></table>
<p>
<td width=46%>
<table width=100%>
<tr valign=top>
<td width=21%>
<div align=right><font size=1 face="sans-serif">To</font></div>
<td width=78%><font size=1 face="sans-serif">users@activemq.apache.org</font><font
size=3>
</font>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">cc</font></div>
<td>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">Subject</font></div>
<td><font size=1 face="sans-serif">Unable to build 5.0 source</font></table>
<br>
<br>
<table width=100%>
<tr valign=top>
<td width=49%>
<td width=50%></table>
<br></table>
<br><font size=3><br>
<br>
</font><font size=2 face="sans-serif"><br>
<br>
I'm trying to build the 5.0 source from SVN but it continuously fails.
The SVN URL that I am using is <br>
<br>
https://svn.apache.org/repos/asf/activemq/tags/activemq-5.0.0</font><font size=3>
</font><font size=2 face="sans-serif"><br>
<br>
I'm using maven with the method described on the build page: http://activemq.apache.org/building.html</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
but each time I try to compile I get the following error:</font><font size=3>
</font><font size=2 face="sans-serif"><br>
[INFO] ----------------------------------------------------------------------------</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
[INFO] Building ActiveMQ :: Performance Test Plugin</font><font size=3>
</font><font size=2 face="sans-serif"><br>
<br>
[INFO] &nbsp; &nbsp;task-segment: [install]</font><font size=3> </font><font
size=2 face="sans-serif"><br>
<br>
[INFO] ----------------------------------------------------------------------------</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
[INFO] [plugin:descriptor]</font><font size=3> </font><font size=2 face="sans-serif"><br>
<br>
[INFO] Using 2 extractors.</font><font size=3> </font><font size=2 face="sans-serif"><br>
<br>
[INFO] Applying extractor for language: java</font><font size=3> </font><font
size=2 face="sans-serif"><br>
<br>
[INFO] ------------------------------------------------------------------------</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
[ERROR] FATAL ERROR</font><font size=3> </font><font size=2 face="sans-serif"><br>
<br>
[INFO] ------------------------------------------------------------------------</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
[INFO] syntax error @[45,77] in file:/s:/activeMQ-5.0/activemq-tooling/maven-activemq-perf-plugin/src/main/java/org/apache/activemq/tool/reports/plugins/ThroughputReportPlugin.java</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
[INFO] ------------------------------------------------------------------------</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
[INFO] Trace</font><font size=3> </font><font size=2 face="sans-serif"><br>
<br>
com.thoughtworks.qdox.parser.ParseException: syntax error @[45,77] in file:/s:/activeMQ-5.0/activemq-tooling/maven-activemq-perf-plugin/src/main/java/org/apache/activemq/tool/reports/plugins/ThroughputReportPlugin.java</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
 &nbsp; &nbsp; &nbsp; at com.thoughtworks.qdox.parser.impl.Parser.yyerror(Parser.java:504)</font><font
size=3>
</font><font size=2 face="sans-serif"><br>
<br>
Am I missing something? <br>
<br>
Chris Mathrusse<br>
christopher.mathrusse@sybase.com<br>
Sybase, Inc<br>
One Sybase Drive<br>
Dublin, CA 94568<br>
(925) 236-5553</font><font size=3> </font>
<br>

Mime
View raw message