activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Gunther" <Jeff.Gunt...@intalgent.com>
Subject Re: Messages does not show up in database
Date Wed, 21 Nov 2007 17:33:45 GMT
Are you using the high performance disk journal?

> On 21/11/2007, Erlend Aakre <erlend.aakre@intrapoint.com> wrote:
>>
>> I changed the persistenceAdapter to JDBC and a mysql database and  
>> user has
>> been set up (tables has been automatically generated). But when I add
>> messages to the queue nothing is saved in the database.
>>
>> The messages can be retrieved OK from the queue, but are not saved  
>> when
>> added, or when activemq terminates.
>>
>> <persistenceAdapter>
>>      <jdbcPersistenceAdapter dataSource="#mysql-ds"/>
>> </persistenceAdapter>
>>
>> I'm running a clean install of activemq 4.1.1, the datasource is  
>> correctly
>> set up:
>>  <bean id="mysql-ds" class="org.apache.commons.dbcp.BasicDataSource"
>> destroy-method="close">
>>    <property name="driverClassName" value="com.mysql.jdbc.Driver"/>
>>    <property name="url"
>> value="jdbc:mysql://localhost/activemq?relaxAutoCommit=true"/>
>>    <property name="username" value="activemq"/>
>>    <property name="password" value="activemq"/>
>>    <property name="poolPreparedStatements" value="true"/>
>>  </bean>
>>
>> And I cant understand why stuff is not written to DB.. any insights  
>> would be
>> appreciated :)
>> Java 1.6, mysql 5.0.38, mysql-connector-java-5.1.5, Vim version 7.0
>>
>> Regards
>> Erlend

Mime
View raw message