activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shirley <hnsxy...@yahoo.com.cn>
Subject why Activemq-cpp 2.1 client couldn't receive message?
Date Thu, 29 Nov 2007 03:23:35 GMT

Hello!
    Recently ,I' m working on the activemq message broker .I use  the
example codes which download from the official webside.I have tried many
times. although, the producer can sent message to a queque installed by the
server(another computer) succeful, but ,it failed on consumer receiving a
message from a queque, I  have seen about many papers ,but they  still can't
solve my problem, I still don't  known what's the problem with the codes!
and the other java client  works well , indicating   that the server is well
configured.
     I just modify those below  parameters:
1. brokerURL ="tcp://10.1.14.88:61616"
		"?wireFormat=openwire"
		"&transport.useAsyncSend=true";
2. usetopic = false;
3. session->createQueue("dyx"); //the queue named qyx exist, there are  many
message in it. 


   it  has been puzzled  me for several days.
   I beg somebody help me solve this question! Thanks very much!

PS :
    I have seen that paper called "Java Producer and C++ Consumer", I Copied
the full code source, of course plus the key sentence "conn->start ();",
but,  It still fail……
-- 
View this message in context: http://www.nabble.com/why--Activemq-cpp-2.1-client-couldn%27t-receive-message--tf4894894s2354.html#a14018725
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message