activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erlend Aakre <erlend.aa...@intrapoint.com>
Subject Re: Messages does not show up in database
Date Thu, 22 Nov 2007 10:20:40 GMT

Yes, that seems to be it: (from bin/browse):
JMS_HEADER_FIELD:JMSDeliveryMode = non-persistent

Going to try and set the headers now, but so far everything is being added
as custom-header.. Better look at some STOMP php details.

Thanks for the tip

Erlend



James.Strachan wrote:
> 
> On 22/11/2007, Erlend Aakre <erlend.aakre@intrapoint.com> wrote:
>>
>> My producer is very simple:
>>
>> $c = new StompConnection("localhost");
>> $c->connect("user", "pass");
>> $c->send("/queue/myqueue", "msg: " . $_GET["msg"]);
>> $c->disconnect();
>>
>> and I can read the messages from my consumer, and I can verify by the
>> bin/browse program that the messages are in the queue.. the messages are
>> just never put into DB
> 
> Which language is that btw :) PHP or Perl (don't know either too well :).
> 
> I wonder if the client is setting that the message is persistent. e.g.
> try adding a header "persistent" of "true"
> 
> -- 
> James
> -------
> http://macstrac.blogspot.com/
> 
> Open Source Integration
> http://open.iona.com
> 
> 

-- 
View this message in context: http://www.nabble.com/Messages-does-not-show-up-in-database-tf4851631s2354.html#a13894179
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message