activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erlend Aakre <erlend.aa...@intrapoint.com>
Subject Messages does not show up in database
Date Wed, 21 Nov 2007 17:21:23 GMT

I changed the persistenceAdapter to JDBC and a mysql database and user has
been set up (tables has been automatically generated). But when I add
messages to the queue nothing is saved in the database.

The messages can be retrieved OK from the queue, but are not saved when
added, or when activemq terminates.

<persistenceAdapter>
      <jdbcPersistenceAdapter dataSource="#mysql-ds"/>
</persistenceAdapter>

I'm running a clean install of activemq 4.1.1, the datasource is correctly
set up:
  <bean id="mysql-ds" class="org.apache.commons.dbcp.BasicDataSource"
destroy-method="close">
    <property name="driverClassName" value="com.mysql.jdbc.Driver"/>
    <property name="url"
value="jdbc:mysql://localhost/activemq?relaxAutoCommit=true"/>
    <property name="username" value="activemq"/>
    <property name="password" value="activemq"/>
    <property name="poolPreparedStatements" value="true"/>
  </bean>

And I cant understand why stuff is not written to DB.. any insights would be
appreciated :)
Java 1.6, mysql 5.0.38, mysql-connector-java-5.1.5, Vim version 7.0

Regards
Erlend


-- 
View this message in context: http://www.nabble.com/Messages-does-not-show-up-in-database-tf4851631s2354.html#a13881708
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message