activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bradford <brad.stimp...@gmail.com>
Subject Re: ActiveMQ 4.1.1 Memory Leak with CMS
Date Tue, 20 Nov 2007 17:06:30 GMT

Hey,

I've done some more digging and I believe the issue I am seeing is related
to this bug:

https://issues.apache.org/activemq/browse/AMQ-1437

If any one can give me any hints on where in the code I can search to try
and fix this bug, I would really appreciate the help.

Many Thanks,
Brad

bradford wrote:
> 
> Hey,
> 
> I'm trying to setup a CPP client to connect with ActiveMQ 4.1.1.  I'm
> using activemq-cpp-2.1.1 and I have it set up to create and tear down
> several connections within a thread.
> 
> It seems that as the test progresses, the message broker continues to
> consume more and more memory until a java.lang.OutOfMemoryException
> occurs.
> 
> I don't think it is a problem on the cpp-client side as the memory and cpu
> consumption seems okay.  It may have something to do with my program;
> however,  I simply adapted the example/main.cpp program found in the
> source package.  It could be an issue with the configuration as I am not
> 100% familiar with ActiveMQ.
> 
> If anyone has any experience with this, I would greatly appreciate the
> help. 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ-4.1.1-Memory-Leak-with-CMS-tf4793982s2354.html#a13860938
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message