activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tpounds <trevor.pou...@gmail.com>
Subject Re: ActiveMQ - Spring
Date Sat, 10 Nov 2007 18:34:38 GMT

Are you using the correct namespaces/schemas for spring and activemq? Are you
using the spring ClassPathXmlApplicationContext directly or the xbean
version?  The version provided by xbean doesn't require the spring
namespaces/schemas to be defined...If you look through the bundled activemq
XML files you will see there are no references to spring schemas and
namespaces because they use xbean version.
 

ktecho wrote:
> 
> I don't know if this is your problem, but I lost a lot of time with a
> similar problem that was resolved by changing the spring-x.x.jar that
> comes with ActiveMQ with the latest version from the 1.x branch of Spring.
> 
> Just delete the .jar that comes with ActiveMQ and put the .jar you
> downloaded with Spring 1.x.
> 
> I don't know why a stable release of ActiveMQ has this kind of
> compatibility issues. Perhaps a 4.1.2 should be released to address this
> and other important issues.
> 
> Cheers,
> 
> Luis Miguel GarcĂ­a Mancebo
> 
> 
> 
> 
> navneek wrote:
>> 
>> Hi,
>> 
>> Im trying to use the Spring approach to access the components in
>> activemq.xml
>> I tried to load this file using the following syntax
>> 
>> ApplicationContext context = new
>> ClassPathXmlApplicationContext("activemq.xml");
>> 
>> But it throwing lot of xmlns(xml namespace) exceptions while im running
>> this java code. Could anyone help me.
>> 
>> Many thanks!,
>> -Nava.
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ---Spring-tf4718762s2354.html#a13684662
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message