activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bradford <brad.stimp...@gmail.com>
Subject Ubuntu activemq-cpp-2.1.1 build
Date Fri, 09 Nov 2007 22:19:11 GMT

Hey Guys,

Im trying to build activemq-cpp-2.1.1 on my Ubuntu 7.10 box and I'm running
into a bunch of problems.

Ive followed the readme and installed uuid, cppunit, autoconf-2.61,
automake-1.96, libtool-1.5.24 but when I run ./autogen.sh, I get the
following error:
configure.ac:43: error: possibly undefined macro: AM_INIT_AUTOMAKE
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

I did some searching and it was suggested to re-install build-essential (I
did this but still no go).

I was able to get autogen to work by running aclocal prior to running
./autogen.sh.  I'm not very familiar with the cpp build tools, so I'm unsure
if this is the correct thing to do.  ./autogen.sh then threw the following
error:
.... (ran okay then) ...
doxygen-include.am:52: DX_COND_doc does not appear in AM_CONDITIONAL
Makefile.am:36:   `doxygen-include.am' included from here
autoreconf: automake failed with exit status: 1


After autogen has run, I can then execute configure; however, I get the
following error:
.... (ran okay then) ...
checking for time... yes
checking for ftime... yes
checking for cppunit-config... /usr/bin/cppunit-config
checking for Cppunit - version >= 1.10.2... 1.12.0
checking for pthread_create in -lpthread... yes
./configure: line 26002: syntax error near unexpected token `CHECK_ADDRINFO'
./configure: line 26002: `CHECK_ADDRINFO()'

I really appreciate any help you can give me.


-- 
View this message in context: http://www.nabble.com/Ubuntu-activemq-cpp-2.1.1-build-tf4780388s2354.html#a13676113
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message