activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Albert Strasheim" <full...@gmail.com>
Subject Re: The matching wildcard is strict error with AMQ 5 (was Re: AMQ 4.1 and Spring XML beans)
Date Thu, 22 Nov 2007 07:51:31 GMT
Hello all

I've been getting a few queries about this issue from various people 
off-list, so I thought I'd reply here with some useful ideas for future 
generations struggling with this issue.

My advice:

If I remember correctly, you should check your Spring XML, the ActiveMQ 
schema and the schema.location in the ActiveMQ JAR *very* carefully to make 
sure that all the various URIs and other IDs match up.

And be sure to read: http://erik.jteam.nl/?p=27

One person who followed this advice replied to me, saying:

You are right,i have corrected the namespace decleration in the spring xml 
and it works now. But i guess i cannot use the spring property placeholders 
for amq:... namespaces.It complains a lot.

Hope this helps.

Cheers,

Albert

----- Original Message ----- 
From: "Albert Strasheim" <fullung@gmail.com>
To: <users@activemq.apache.org>
Sent: Friday, September 21, 2007 10:41 PM
Subject: Re: The matching wildcard is strict error with AMQ 5 (was Re: AMQ 
4.1 and Spring XML beans)


> Found the bug somewhere between the chair and the keyboard.
>
> ----- Original Message ----- 
> From: "Albert Strasheim" <fullung@gmail.com>
> To: <users@activemq.apache.org>
> Sent: Friday, September 21, 2007 10:16 PM
> Subject: The matching wildcard is strict error with AMQ 5 (was Re: AMQ 4.1 
> and Spring XML beans)


Mime
View raw message