activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bidimus <bidi...@gmail.com>
Subject Networked brokers and durable bridges
Date Thu, 25 Oct 2007 20:54:45 GMT

I'm working with a configuration of three networked brokers each with a
bridge to the other two.  The purpose is to provide redundancy as well as
load balancing.

It works as expected for Queues and non-durable topic subscriptions.

Durable topic subscriptions though seem to be exhibiting a problem and I'm
not sure if it's the release I'm using or a configuration problem.  When a
durable subscription is made, durable subscriptions are made across the
bridge on the other two brokers.  When the durable subscription is destroyed
though, the two durable bridges aren't destroyed with it.

I'm currently running the 5.0 snapshot from 10-23-2007.  This is necessary
as I've found leaks and other issues with all of the 4.x releases.

My configurations look esentially like this:

   <transportConnectors>
       <!-- <transportConnector name="openwire" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/> -->
       <transportConnector name="openwire" uri="tcp://localhost:61618" />
    </transportConnectors>

    <!-- The store and forward broker networks ActiveMQ will listen to -->
    <networkConnectors>
      <networkConnector name="bridge"
uri="static://(tcp://localhost:61617,tcp://localhost:61616)"
dynamicOnly="true" networkTTL="1" />
    </networkConnectors> 

With port numbers and broker names changed on each broker.

Topics and subscriptions are made by the clients at run time.

If this is expected behavior then is there a workaround for this scenario?

Thanks in advance,

- Jim
-- 
View this message in context: http://www.nabble.com/Networked-brokers-and-durable-bridges-tf4693602s2354.html#a13415793
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message