activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pat ES <pat.geo...@eyestreet.com>
Subject JMX "browse" functions return empty
Date Thu, 25 Oct 2007 15:48:59 GMT

My customer has ActiveMQ 4.1.1.  They asked me to create a custom 
http://www.jmanage.org/ jManage  dashboard for them to easily inspect their
queues.  The dashboard basically shows two things - the current queue size
as returned by getQueueSize(); a list of all the messages in the queue as
returned by browse().

Everything works fine in my local and their test environments.  In their
Prod environment getQueueSize() returns ~600 messages but browse() returns
nothing.  I've confirmed this by using jconsole as well.  It's not just
browse() that returns nothing but also browseAsTable() and browseMessages().

The customer tells me they had this problem before and "fixed" it by
switching to an XML serializer for both in and out.

Has anyone seen this before or know what could be going on?  I'll admit I'm
pretty new to ActiveMQ and JMX so it's entirely possible I'm missing
something obvious (persistence, perhaps?).  For instance, I noticed the
persistenceAdapter block in their conf/activemq.xml file is commented out. 
Would that do it?

Thanks.

Pat
-- 
View this message in context: http://www.nabble.com/JMX-%22browse%22-functions-return-empty-tf4691619s2354.html#a13409215
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message