activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From navneek <nava.a...@gmail.com>
Subject Messages are not getting persisted in database table.(jdbcPersistenceAdapter>
Date Thu, 25 Oct 2007 11:28:16 GMT

Hi,

Im using the following configuration for persisting messages into oracle
database. Ultimately When I start activemq the tables (activemq_acks,
activemq_lock, activemq_msgs) are created but it is not holding any message
in table named 'activemq_msgs'. When I post messages into Broker, msg
staying in broker only... but msg are not going into dadabase
table(activemq_msgs).Table data remains empty.. Please let me know if im
missing anymore configuration. I want to populate this table with the
messages im posting in broker.

My configuration:
--------------------------------------
<broker xmlns="http://activemq.org/config/1.0" brokerName="localhost"
persistent="true">
 <persistenceAdapter>
        <jdbcPersistenceAdapter dataSource="#oracle-ds"
useDatabaseLock="true"/>
    </persistenceAdapter>

<bean id="oracle-ds" class="org.apache.commons.dbcp.BasicDataSource"
destroy-method="close">
    <property name="driverClassName"
value="oracle.jdbc.driver.OracleDriver"/>
    <property name="url" value="jdbc:oracle:thin:@mydb:1521:orclcore"/>
    <property name="username" value="scott"/>
    <property name="password" value="testpw"/>
    <property name="poolPreparedStatements" value="true"/>
  </bean>

-- 
View this message in context: http://www.nabble.com/Messages-are-not-getting-persisted-in-database-table.%28jdbcPersistenceAdapter%3E-tf4690259s2354.html#a13404857
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message