activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From appi03 <arpit.s...@sparta.com>
Subject Broker Connection
Date Fri, 19 Oct 2007 20:10:06 GMT

I have been running in to this problem and need some help. Here is my
configuration

Client 1 (Producer) -> Broker 1
<transportConnector name="openwire" uri="tcp://localhost:61616" />

<networkConnector name="host1" uri="static://(tcp://10.11.12.134:61616)"
failover="true" /> 


Client 2 (Consumer) -> Broker 2
<transportConnector name="openwire" uri="tcp://localhost:61616" />

<networkConnector name="host1" uri="static://(tcp://10.11.12.135:61616)"
failover="true" /> 

The producer keeps producing the messages and the consumer consumes certain
number of messages and then stops. There aren't any other consumers present.

So as soon as the consumer application goes down, broker 1 retries to
connect to broker 2. For some reason the connection between broker 1 and 2
gets lost. I tried restarting the consumer application, which didn't seem to
work either. I basically had to restart the broker 1 to see that consumer
was up and running again. 

What i am not understanding is why does the connection between broker 1 and
2 gets lost. Initially they establish the connection and producer is
producing messages. As soon as i start and stop the consumer application,
the producer broker displays this message:

2007-10-18 13:46:16,852 [Thread-4       ] INFO  DemandForwardingBridge        
- Network connection between vm://localhost#0 and
tcp://10.11.12.135:61616(localhost) has been established.

2007-10-18 13:46:59,727 [tcher: 13079252] INFO  DemandForwardingBridge        
- Network connection between vm://localhost#0 and tcp://10.11.12.135:61616
shutdown due to a local error: java.lang.IllegalArgumentException: The
subscription does not exist: ID:PCSHAH-4445-1192729447242-3:1:1:1

2007-10-18 13:48:41,415 [85.37.184:61616] INFO  FailoverTransport             
- Transport failed, attempting to automatically reconnect due to:
java.io.EOFException
java.io.EOFException
	at java.io.DataInputStream.readInt(Unknown Source)
	at
org.apache.activemq.openwire.OpenWireFormat.unmarshal(OpenWireFormat.java:267)
	at
org.apache.activemq.transport.tcp.TcpTransport.readCommand(TcpTransport.java:156)
	at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:136)
	at java.lang.Thread.run(Unknown Source)

I am not sure what the underlying problem is. Would having two consumers
help? I was thinking that if the consumer application went down the messages
would pretty much be lost but the connection between broker 1 and 2 should
still be up. So if the consumer application comes up again, it can start
consuming messages. 

Some help would really be appreciated.

Thanks,

-- 
View this message in context: http://www.nabble.com/Broker-Connection-tf4655518s2354.html#a13302149
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message