activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From appi03 <arpit.s...@sparta.com>
Subject Re: Consumer connection lost
Date Fri, 19 Oct 2007 15:24:03 GMT

yea i am using failover. I did some more work on it.

So my producer keeps producing messages. the consumer application on a
different machine consumes certain number of messages and stops. Once the
consumer application exits, the brokers also loose connection. 

I am thinking that only the connection that connects the consumer to the
broker should stop not the connection between two brokers. 

Has anyone seen this problem?

It seems pretty odd.


James.Strachan wrote:
> 
> Are you using failover?
> 
> http://activemq.apache.org/how-can-i-support-auto-reconnection.html
> 
> On 18/10/2007, appi03 <arpit.shah@sparta.com> wrote:
>>
>> I am learning about ActiveMQ and just started using it this week. So I am
>> in
>> the preliminary stages but I was wondering if someone can answer this
>> question for me. I have a set up where i am running two brokers, one on
>> Windows and the other one on Linux. They are on the same network; windows
>> box as a producer and Linux box as a consumer.
>>
>> I can send and receive messages. But in the middle, the connection to the
>> consumer is lost and I can't receive any more messages. The producer
>> keeps
>> producing the messages.
>>
>> I receive this error (The error shows up on the producer):
>>
>> shutdown due to a local error: java. lang.illegalArgumentException: The
>> subscription does not exist: ID:------
>>
>> Then once i restart the brokers again. Everything seems to work fine
>> until I
>> get the error again. The error shows up after sending certain number of
>> messages.
>>
>> Some help would be appreciated. Thanks in advance
>>
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Consumer-connection-lost-tf4647781s2354.html#a13277028
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> James
> -------
> http://macstrac.blogspot.com/
> 
> Open Source SOA
> http://open.iona.com
> 
> 

-- 
View this message in context: http://www.nabble.com/Consumer-connection-lost-tf4647781s2354.html#a13296861
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message